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These Release Notes provide a reference to known issues in the MapInfo Professional 9.5 
product and provide information on customer issues that have been addressed and corrected. 
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Known Issues with the Current Version

Data Access Issues
SQL Server 2008 Time Data. If you download time data from a SQL Server 2008 
database but there is no data in that column, MapInfo Professional considers it a 
string. Time data in this type of database table is downloaded correctly. 

WFS-T Issues 
One Object Type per Table Limitation. Some servers and backends (such as 
Shape) only support one object type per WFS Transaction table. MapInfo 
Professional does not have this limitation, but if the server does, we cannot 
correct it. If you connect to a server that only supports one object type per table 
(such as, regions), and you add another object type to the linked table (such as a 
point), the server will display an error when you try to commit the changes. The 
message that displays is controlled by the server and not MapInfo Professional; 
we just pass this error message through. 

Mapping Oracle 11g SRIDs to MapInfo Professional 
Oracle 11g contains over 4400 coordinate system definitions in the CS_SRS 
table, many of which are new for this version of Oracle. MapInfo Professional 
maps about 1000 of these definitions automatically and maintains an internal 
lookup list that maps other Oracle SRIDs to coordinate system definitions that 
MapInfo Professional typically uses. This lookup list makes it easier to work with 
your data in these projections. 
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Note: Easyloader also uses this lookup list to populate the MAPCATALOG and Oracle metadata with the appropriate 
coordinate system information. The changes covered in this section will also be available in Easyloader 9.5.

For MapInfo Professional 9.5 we have selectively updated the internal lookup table to support read/write and make 
table mappable operations of the following coordinate systems:

• "French Lambert I Carto\p27581"

• "French Lambert II Carto\p27582"

• "French Lambert III Carto\p27583"

• "French Lambert I Nord\p27591"

• "French Lambert II Centre\p27592"

• "French Lambert III Sud\p27593"

We will continue to update this lookup table to support a more complete list of these SRIDs in the Maintenance 
Release of MapInfo Professional 9.5.

Mapping the Finnish KKJ

The automatic mapping between the SRID and coordinate system definitions in MAPINFOW.PRJ file is tolerant of 
some differences. Specifically, the following Finnish KKJ definitions are mapped to the same set of Oracle SRIDs:

Internally, MapInfo Professional uses this set of coordinate system definitions interchangeably when you make a table 
mappable. When you download Oracle 11g data using MapInfo software, though we map different SRIDs to the same 
coordinate system, we retain the original coordinate system in the COORDINATESYSTEM column of MAPCATALOG 
to ensure accuracy.

MapBasic Issue
The MapBasic Reference Guide and Help System documentation describe some new attributes we have added to the 
RasterTableInfo() function. Specifically:

Further, the MAPBASIC.DEF chapter in the Reference Guide file should include the IMAGE_TYPE_RASTER and the 
IMAGE_TYPE_GRID entries but it does not. These attributes are present in the actual MAPBASIC.DEF file.

Oracle SRID Finnish Coordinate System (2003) Finnish Coordinate System (Old, 1996)

294912 Finnish KKJ Zone 1\p2391 Finnish KKJ Zone 1

294913 Finnish KKJ Zone 2\p2392 Finnish KKJ Zone 2

294914 Finnish KKJ Zone 3\p2393 Finnish KKJ Zone 3

294915 Finnish KKJ Zone 4\p2394 Finnish KKJ Zone 4

Attribute Code RasterTableInfo Returns:

RASTER_TAB_INFO_IMAGE_TYPE SmallInt result, representing the type of image:

• IMAGE_TYPE_RASTER - for raster images

• IMAGE_TYPE_GRID - for grid images

• IMAGE_TYPE_WMS - for WMS images
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Licensing Issues Resolved
Some of the new licensing features required some changes and corrections. These have been listed below. 

Corrected — Invalid License Activated “Successfully” 
Some users received activation codes that were issued incorrectly by the Pitney Bowes MapInfo license system. The 
license codes that were issued were valid for another product or for another version of MapInfo Professional. When 
these users tried to activate their licenses, the message that displayed indicated that the activation was successful, but 
these users found out later that the courtesy license was in effect. 

We are doing our best to correct the problem of issuing incorrect licenses, but if this error should occur again, we have 
added two, more precise messages to explain the problem and to help you get back to the proper activation of the 
application. 

If you have a license for another product, this message displays:

Invalid product feature license was activated. The activated feature is <product
name> while the expected feature is MapInfo Professional <version number>.

If you have a license for MapInfo Professional but the version is incorrect, this message displays:

Invalid product version license was activated. The activated version is <wrong
version> while the maximum version that could be activated is <right version>.

If you receive either of these error messages, please call Pitney Bowes MapInfo Customer Service at 1.800.552.2511, 
option #3 and explain the problem to the customer service representative. You will need to give them your company 
name and serial number over the phone. They will give you the correct activation codes so you can activate MapInfo 
Professional properly.

Technical Support to the Rescue! 
During activation, some users reported seeing an error message that directed them to contact Pitney Bowes MapInfo 
Customer Service. Typical messages read:

We are unable to validate your license due to <error number>. Please contact 
Pitney Bowes MapInfo Customer Support.

This error message should have directed users to call their regional Technical Support associates. Contact information 
for Technical Support is listed in the next table. This error message has been corrected in our code.

Your Region Contact Information  Hours

The Americas Phone: 518.285.7283
Fax: 518.285.6080 
techsupport@mapinfo.com

Monday - Friday from 8 am - 7 pm EST, 
excluding Holidays. Closed between 10:30 
am - 11:30 am on Mondays for training. 

Europe/
Middle East/
Africa

Phone: 44.1753.848229 
Fax: 44.1753.621140 
support-europe@mapinfo.com

Monday - Friday from 8 am to 5 pm GMT, 
excluding Holidays.

Germany Phone: +49 (0) 6142-203-400 
Fax: +49 (0) 6142-203-444 
supportgermany@mapinfo.com

Monday - Friday from 9 am to 5 pm MEZ, 
excluding Holidays.

Asia-Pacific Phone: 61.7.3844.7744 
Fax: 61.7.3844.2400 
ozsupport@mapinfo.com

Monday - Friday from 9 am and 5 pm EST 
Australian Eastern Standard Time, 
excluding Holidays.
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Upgrading an Evaluation Copy Resulted in Misleading Error Message 
Users of the evaluation version of MapInfo Professional 9.0.1 reported that when they tried to upgrade their evaluation 
copy to a license server activation, a misleading error message displayed:

Client activation is not allowed to activate: <server serial number and access code>.
Check the license model to make sure a client can activate. [Incident# 4931-1114693] 

We have updated this error message to make it clear that you cannot perform this kind of upgrade directly. The error 
message now reads:

The Serial Number you entered indicates a server based license. Please cancel the
current activation process, exit and restart MapInfo Professional to complete this
process.

Map Issues Resolved
The following mapping-related issues have been corrected.

Region Pen Persistence Improved 
In the past, setting the border pen preferences for Region Styles did not persist in a new session. When you changed 
the border style for a region in the Region Style dialog box, the change would persist only through the session. We 
have corrected this issue to persist the pen preference that is selected in the Region Styles dialog box.

TAB Files Containing Non-English Characters Do Not Corrupt MWS Files 
Formerly, saving .tab files with characters such as å, ä, and ö resulted in corrupted MWS files. We have corrected the 
way this data is stored to prevent this from occurring. 

Callout Lines Changed when Saving a Workspace 
In MapInfo Professional 8.x versions call-out lines you created using the Text tool in the Layout did not hold style 
changes when you saved the map as a workspace. This occurred because when you saved the Layout in this way, the 
application would use the default pen settings rather than the new settings you had created. We have corrected this 
issue to use the latest settings.

Keyboard Shortcuts Changed 
We found that there were some conflicting shortcuts in the MapInfo Professional program that affected how people 
accessed frequently used dialog boxes. We have updated these keyboard shortcuts as follows:

Dialog Box Displayed Old Hot Key New Hot Key

Geocode Using Server Alt A +U Alt A + V

Universal Data Table Refresh Alt A +U Alt A + N

Create Layout from Template (Layout Template Tool) Alt T +T Alt T + T+ T +U
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Remote Database Issues Resolved

Crash Issue Resolved for SQL Queries
When running MapInfo Professional 9.0.2, users reported that MapInfo Professional closed suddenly when they ran a 
SQL Query using a Group by or Order by condition on columns with character fields of 254 or more. This occurred due 
to insufficient memory allocation. We have corrected this problem by increasing the amount of memory allotted for this 
process to correct the problem.

Self Intersecting Regions Issue Resolved 
Some Oracle 10.x users reported that regions that contain no self-intersections display random self intersecting arcs 
when downloaded into MapInfo Professional. We have corrected this issue so the Oracle data is downloaded and 
displayed properly.

Unclear Error Message when using Creating a Table in SQL Server 2005 
When you created a table in the Make Table Mappable dialog box with a name longer than 30 characters in a SQL 
Server 2005 database, this error message would result:

ODBC Error: ODBC RC=-1, ODBC SQLState=22001, DBMS RC=8152, DBMS Msg=[Microsoft]
[ODBC SQL Server Driver][SQL Server]String or binary data would be truncated.. 
The table you have chosen cannot be made mappable. To be made mappable, a table 
must contain a spatial column, or at least two numeric columns.

Note: This error message did not display if you used EasyLoader to create the table. 

We have replaced this error message with a shorter and more descriptive error message explaining the 32 character 
table name limit.

Table <table name> is not mappable. Filename exceeds 32 character limit.

Unexpected Save Conflict with Some Linked Tables 
If you have downloaded a SQL Server spatial table as a linked table into MapInfo Professional 8.5 or later, you may 
have noticed some unexpected save conflicts. These save conflicts occurred when you:

a. Added any type of object to this downloaded table 

b. Saved it to the server but did not refresh it locally 

c. and then tried to move the new object

In MapInfo Professional 8.5, we changed code to reset the primary key for inserted records in linked tables. As a result, 
the local key value was only being reset for Oracle tables. In this SQL Server case, the save conflict was the difference 
between the local value of the primary key -- which had never been set -- and the server value which was set when you 
saved the linked table with the new object data in it. We have updated this code to apply to all linked tables to correct 
this issue.

Uploading Data with some Lat/Long Coordinate Systems Resulted in Null SRIDs
Some users reported that uploading Oracle tables with the Lat/Long NAD83 coordinate system resulted in null SRID 
entries in the table. This happened when using both EasyLoader and the File > Save Copy As uploading methods. We 
have updated the lookup tables associated with some coordinate systems in this version to resolve this issue. For 
more information about Oracle 11g SRID issues, see Mapping Oracle 11g SRIDs to MapInfo Professional on 
page 1 for more information.
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Oracle Tables Not Displaying in Open Dialog Box 
Users reported that some of the Oracle tables, such as P_CONS_AREA_xxx, were no longer displaying in the Open 
dialog box. This has occurred since we added the Oracle Workspace Manager to MapInfo Professional because the 
application filtered out assistant tables for version-enabled tables. These assistant tables contained the table suffixes 
listed below. Unfortunately any table that contained these sequences of characters was also filtered out. To resolve this 
issue we have changed the way we filter the tables to remove the only the assistant tables while allowing other tables 
that contain these characters to be displayed.
_

Tools Issues Resolved

International DistanceCalc Tool Issue Resolved 
When you used the DistanceCalc tool in a non-English locale, the following error would display when you clicked the 
Calculate Distance button.

Calculate_Distance: The operation has been interrupted.
Field Origin does not exist in table TempBrowser.

This issue has been resolved. The DistanceCalc tools is again fully internationalized.

Selection Disappears After Switching Tools 
Since MapInfo Professional 8.5, there has been an unintended change in selection behavior with seamless tables. 
When you used the Selection tool to make a selection and then selected another tool and then returned to the 
Selection tool, the application did not maintain the selection. We have corrected this issue so the selection is 
maintained.

Use the CoordSys Bounds Manager Tool to Give Data More Room
If you have used the CoordSys Bounds Manager tool before, you may have noticed that the tool created the coordinate 
system bounds to the exact dimensions of the data you gave it. This caused problems when you wanted to buffer the 
map. We have updated the tool so you can add a buffer percentage to the bounds that the tool creates for the data. 
Use the Tool Manager to add the CoordSys Bounds Manager to the Tools menu before starting the tool.

To add a buffer percentage to your data using the CoordSys Bounds tool:

1. Open the data you want to create bounds for.

2. Choose Tools > CoordSys Bounds Manager > Check and set table coordinate system bounds to display the 
CoordSys Bounds Manager dialog box.

• _AUX • _DIF2 • _PKD

• _BASE • _LOCK • _PKDB

• _BPKC • _HIST • _PKDC

• _CONF • _LT • _RI$B

• _CONS • _LTB • _RI$T

• _DIFF • _MW • _VTB

• _DIF1 • _PKC
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This new field allows you to specify the additional buffer you want to add to the bounds of the selected 
table. This value must be a positive number. 

3. Select the table you want to create bounds for in the Tables box.

4. Type the buffer percentage you want to add to the table bounds and click Optimizing CoordSys Bounds. The 
Table CoordSys Bounds values update to include the new buffer amounts.

5. Click Save Table As with CoordSys Bounds to save the change and create the new bounds.

Grid Maker Tool No Longer Allows Invalid Extents 
The Grid Maker v1.3 tool allowed you to create a grid of horizontal and vertical lines that simulate latitude and 
longitude lines (also called graticules). Users reported that the tool allowed then to enter invalid extent values when 
creating this grid. The tool did not display an error when it encountered this problem but rather created an empty layer. 
We have upgraded this tool (to 1.4) to prevent the entry of invalid extents. 

Note: Add the Grid Maker tool to the Tools menu using the Tool Manager.

To see this change:

1. Choose Tools > Grid Maker > Make Grid to display the Grid Maker (Version 1.4) dialog box.
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2. Enter very large extents in each of the North, South, East, and West fields and click OK. An error message results. 

Layout Templates Issue Resolved 
As users began working with the Layout Template tool, they pointed out that we were using the term “Scale”, which is 
an English-only term. We have removed this word so that the dimensions of the map are reported simply as 1: 10000 
with the Layout window.

To see this change:

1. Create a layout template and add a text object.

2. Add a map frame and another text object.

3. Select the  button and place the Scalebar on the template.

4. Save the template and close all of the template files.

5. Open any map layer and choose Map > Create Layout from Template. The Configure Layout dialog box displays.

6. Select the new template from the Template drop-down list.

7. The word “Scale” has been removed from the resulting Scalebar on the Layout.

Printing Issue Resolved

Overlapping Legends in Layout Windows Issue Resolved 
In the past, when you created a Layout with both cartographic legend and theme legend frames and then printed or 
exported this Layout, these frames often overlapped. This was due to a rounding error that has been fixed.

Help System / Documentation Issues Resolved 
At the bottom of each Help System topic is an email address. We encourage you to click this link and send us topics 
that need changing, comments about the text or even suggestions about what more information would be useful in the 
topic. Most of the issues resolved in this product release were sent to us by users just like you. Help us, help you by 
improving the Help System!

Documentation Issues Resolved 
The following issues have been corrected in both the MapInfo Professional User Guide and Help System.

Saving a .WOR and Opening it in Other Locales. In the past, if you created a workspace in English and then sent it 
to someone in another locale, for example, Germany, when the user tried to open the workspace, an error would result. 
We have added a new Help System topic called Saving a .WOR that Can Be Opened in Localized/Unlocalized 
Versions to help users cope with this issue. The text of this topic is below:

Before MapInfo Professional/MapBasic version 9.0.2, if you created a workspace file containing a Layout and then 
sent it to another MapInfo Professional user working in a different locale, the workspace would error when the user 
tried to open it. This occurred because the map name would change due to the change in language.
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We have created a registry entry workaround to prevent this error and allow users in different locales to open the 
workspaces without error. You must enter this registry entry manually.

To prevent map name errors due to the change in locale:

1. From the command line, type regedit. The Registry Editor window displays.
2. Go to My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Mapinfo\Mapinfo\Common.
3. Right-click and select New > DWORD value to create a new DWORD registry entry. 
4. Rename the entry WriteWindowTitle and press Enter. The Edit DWORD value dialog box displays.
5. Type 1 in the Value data field and click OK to save your entry. 
6. Close MapInfo Professional and reopen it.

This corrects the problem by writing the name of the table explicitly in the Layout. This prevents the name change 
when the file changes locales.

Correct Citrix Version Updated in the Documentation We have updated the documentation to correctly state that 
MapInfo Professional works with Citrix 4.0.

Corrected Limits in MapBasic Documentation The Dim statement documentation in the MapBasic Reference Guide 
incorrectly identified the range limits for smallints and integers. The correct values are as follows:

Corrected File Limitations for MapInfo Professional Supported Formats We have updated the MapInfo 
Professional documentation to include the following supported format limitation notes:

• MapInfo Professional only supports the DXF file import to release 13. This has been superseded by the 
Universal Translator and Open Universal Data feature.

• The Open Universal Data feature supports all DXF formats up to the current AutoCAD release. While it is our 
company’s intention to keep pace with the new releases of FME, if you extend the application to import 
AutoCAD DXF files using a newer version of FME before we have upgraded our product, errors may occur

• You can have maximum 500 files open at a time in MapInfo Professional if you remove the HKEY_LOCAL_
MACHINE\SOFTWARE\MapInfo\MapInfo\Common Max Files registry key

• You can have up to 125 files open at a time for editing in MapInfo Professional

Help System Error in Advanced Printing Option "Print Directly to Device" In the previous version of the Help 
System, the Advanced Printing Options dialog box topic indicated that the Print Directly to Device option was no longer 
used. This was incorrect. You can still use the Print Directly to Device option to print images directly.

Oracle Object Types Documentation Corrected We have updated the Oracle Object Type documentation to correct 
geometry type conversion errors as follows:

Location of Dim Statements and Scope of Variables 

Variable Type Description

SmallInt Whole numbers from -32768 to 32767 (inclusive); stored in 2 bytes.

Integer Whole numbers from -2,147,483,648 to +2,147,483,647 (inclusive); stored in 4 bytes.

Value Oracle Geometry Type
Corresponding 
MapInfo Type

4 COLLECTION Geometry is a heterogeneous collection of elements. Collection

5 MULTIPOINT Geometry has multiple points. MultiPoint

7 MULTIPOLYGON Geometry has multiple polygons (more than one exterior 
boundary).

Region
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Several Help System Issues Resolved
DMS and Decimal Degree Index Entries Added. In the past, users found it difficult to find references to degrees, 
minutes, seconds and other coordinate system entries in the Help System Index. We have added more index entries 
on these topics to make them easier to find.

Connecting the Menu Reference Entries with the Related Topics. Some users indicated that the Menu Reference 
entries in the Help System did not tell them enough about the command they wanted to use. We corrected this problem 
by adding related topic entries to these menu references to provide more information. To see an example of this, 
highlight Object > Check Regions and press F1. When you scroll to the bottom of this topic, there are new related 
topics listed. This is part of an ongoing effort to add more related topics to command entries in future releases.

Glossary Entries Reformatted. A couple of releases ago, we updated the way we format the glossary entries to 
make them easier to read and refer to. 

Help System Table of Contents Reorganized. A couple of releases ago, we changed the way we list the help topics 
in the Table of Contents in the Help System.

Our goal was to group information into related subject areas. You may notice that many of these “Chapters” are the 
same as those in the User Guide. We hoped using this structure would make it easier to find the information you are 
looking for. Let us know what you think! Click the email link at the bottom of any Help System topic and send us your 
comments about the new structure!

Other Issues Resolved

Unable to Save a Workspace with a Query from the MapBasic Window
Originally, MapInfo Professional did not allow you to save a workspace with a query in it. This has been corrected for a 
long time but a legacy problem remained when the workspace was saved using a MapBasic statement. We have found 
the code that caused this issue and corrected it. 

To see this resolution:

1. Open any workspace.

2. Choose Query > SQL Select and create a query for one of the workspace tables.

3. Choose File > Save Query as to save this query table.

4. Choose File > Save Workspace As to save the workspace.
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5. Click Close All and then reopen the saved workspace.

6. In the MapBasic window type the following code:
Include "mapbasic.def"
Declare Sub Main
Sub Main

Save Workspace As "B"
End Sub

In the past when you ran this code the following error message displayed.

Unable to save workspace

Now when you type this code, the application saves the workspace as you requested.

DateTime/Time Theme Definitions Not Saved to MWS Format Properly
Our MapXtreme team found errors in the way MapInfo Professional was saving the DateTime- and Time-based 
themes to MWS format. Therefore, we have added new support for creating MWS workspaces with DateTime- and 
Time-based ranged and individual value themes. Currently MapInfo Professional only supports simple expressions 
such as a theme based on the column name only. The new MapBasic DateTime and Time functions have not yet been 
added to MI SQL, which prevents translating the expressions that use them into MWS format.

Resolved — WMS Server Name Dialog Box Displayed some Data Incorrectly 
In the past, when you entered a WMS server name that contained characters other than the English A-Z, the 
application was retrieving the data correctly but not storing it properly. Later, when the application accessed that WMS 
server name for other dialog boxes, the name would display incorrectly. We have corrected the way we store this data 
so the WMS server name displays as it did when the application retrieved it. 

Print Chr$(12) Command Operational Again in the MapBasic Window 
In MapInfo Professional 8.0, you could use the Print Chr$(12) command to print a string to a Message window. For 
example, if you opened the MapBasic window and typed:

Print Chr$(12) + "Hello" 

and pressed Enter, the following would display. 

This was functionality was changed in version 8.5 and later so that this command was ignored. We have corrected this 
Print Chr$ command so a new row is inserted in the MapBasic window as expected.

EOLS — Ignoring Records with No Candidates Caused Sudden Closure
Users reported issues when they used the Envinsa Online Server (EOLS) to geocode records in Interactive Mode. 
When the user came to a record that had no candidate matches and clicked Ignore or Ignore All, MapInfo 
Professional would close suddenly. We have corrected this issue to allow users to ignore records with no candidate 
matches.
MapInfo Professional 9.5 Release Notes 11



Opening MicroStation Design File with FME or Universal Translator Resolved
In the past when some users tried to open a specific Microstation .dgn file using the Open Universal Data command or 
the Universal Translator tool, MapInfo Professional could close suddenly. Safe Software, maker of the translation 
software we use to perform this file translation, has resolved this issue in their new FME 2008 version. We now use this 
version of FME in MapInfo Professional.
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