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Introduction XE "Introduction" 
What is Déjà Vu? XE "What is Déjà Vu?" 
According to The Oxford English Dictionary, déjà vu is “an illusory feeling of having previously experienced a present situation…”.

It is a generally accepted fact that translation work tends to be repetitive. The degree of repetitiveness depends on the field in which each translator specializes, on the authors’ styles, etc. But we have all at one time thought: “Hmm! I know I’ve translated this before, and I don’t feel like doing it again.”

There is also the consistency factor. Our clients expect to find in our work a uniformity of terminology and style. Wouldn’t it be nice to always have a quick answer to “How on earth did I translate this term last month?”

Déjà Vu (DV) provides such an answer, and much more. Déjà Vu is an industrial strength, yet user friendly, powerful and customizable CAT XE "CAT"  (Computer Aided Translation) system.

Overview of CAT concepts

Computer translation systems can be roughly divided into two distinct categories: Machine (or Automatic) Translation (MT) and Machine Assisted Human Translation (MAHT) systems. There are as many synonyms and subtle definitions as there are CAT researchers and tool vendors, but there is a clear distinction between the two categories: the use of linguistic information.

MT systems produce translations by applying linguistic knowledge; they linguistically analyze the source language text, map linguistic structures to their target language counterparts, and construct a translation from scratch.

Translation Memory (TM) systems, the main type of MAHT tool, store previous translations and offer these translations when they encounter identical or similar sentences when translating new material. TM tools learn while you use them, so the more you use them, the more useful they become.

MT systems have two distinct disadvantages. They are entirely language dependent since they must employ advanced linguistic techniques that apply exclusively to a specific language. This means that MT systems are limited in the languages they can handle. In addition to this, since a computer program lacks an understanding of language, context and innuendo, MT systems produce sterile and often awkward translations. Most MT systems have dictionaries and phrase patterns that can be customized, but they can never match the quality of professional human translation.

TM tools, on the other hand, do not translate by themselves at all. A translation memory is a database in which source language sentences are stored together with their translations. When the TM tool is about to translate a new sentence, it searches the translation memory database for the sentence it wants, and presents the user with the translation(s) of the same sentence or similar sentences which the translator did in the past. While in many cases they do not provide a translation per se, providing the translator with similar material helps to ensure the consistency of style and terminology by allowing the translator to easily consult previous translations.

In other words, MT systems translate but lack style, while TM systems do not translate but provide consistency.

Where does Déjà Vu come into all this?

Déjà Vu (DV) goes one step beyond traditional TM tools. While other tools only display exact and fuzzy matches (matches for similar source language sentences), DV intelligently uses the memory database, terminology database and project lexicon to increase the quality of fuzzy matches by working with smaller segments and words. For close fuzzy matches, DV will often produce a perfect translation in your own style. If you specialize in technical translations, you may well find that DV doubles or even triples your productivity.

However, DV is not a mere translation TM tool. It is a full-featured translation environment with many additional features that will increase your productivity and the quality of your work. Whatever type of file you work with, DV presents you with a uniform interface, displaying only translatable text, so you can work comfortably without having to worry about overwriting formatting and layout information. DV includes filters that allow you to translate Word, RTF, PowerPoint, Excel, SGML, FrameMaker, Interleaf, QuarkXPress, Help Contents, HTML (including scripts and ASP), HTML Help, Java Properties, RC and C/C++/Java files. Support for Trados Workbench and IBM TM2 files ensures that even when your customers work with other tools, you can still use DV.

DV provides extensive project management features that simplify the completion of large multifile and multilingual translation projects. Not only can several translators work on the same project in different languages, but several translators can work in the same language on the same project; advanced features such as sentence locking, project lexicons and configurable project security make this a breeze. Project managers can distribute satellite projects and receive/distribute new database entries as separate text files. Powerful statistics options allow you to quickly produce quotes for your customers, to evaluate the progress of a translation, and to accurately bill your customers once the translation is completed.

DV also includes a full-featured terminology management module called TermWatch. TermWatch terminology databases are integrated into the DV translation environment, but TermWatch can be used as a standalone tool. Configurable, system-wide hotkeys allow you to access the terminology databases from within almost any Windows application.

To get you started quickly, DV includes an alignment tool that helps you create memory databases from translations you have done in the past.

Atril and our customers

At Atril, we have a rather unique policy regarding customer relations. Above all, our aim is to help the translator increase his productivity and make his work more comfortable.

This unique view is, for the most part, due to the origins of Déjà Vu. DV was initially developed in 1993 to cater to our own need for a professional translation tool. After evaluating a number of expensive MT and TM systems, we concluded that no tool produced acceptable results at an affordable price. Given our background in both the translation and software businesses, we decided to write DV, not only for ourselves, but also for the professional translator in need of a professional tool.

DV was a first in many areas: the first TM tool for Windows; the first TM tool to directly integrate into Microsoft Word; first 32-bit TM tool (version 2.0); and the first affordable professional translation tool.

Given our understanding of the translation business, we have always been in very close contact with our customers; in fact, we are proud to say that we have formed strong friendships with many of them. We rely on our customers to provide feedback and ideas for new features, and they have come to rely on our prompt and knowledgeable support. This symbiotic relationship is reflected in the fact that virtually every feature we have added since version 1.0 has been developed to address the needs of our customers and prospective buyers. Whenever new features have been requested, we have carefully consulted our users on the best way to implement them, and always produced solutions to benefit all of them.

As a result, you will find that our support services are probably the best in the business. New feature requests and bug fixes are implemented almost immediately, and we regularly help our customers to handle the technical difficulties of large and complex translation projects. We pride ourselves on adopting new technologies as they appear, so you won’t have to wait for a major release before a new file format or feature is supported.

Installation XE "Installation" 
Installing Déjà Vu XE "Installing Déjà Vu" 
This section describes how to install the software included in the Déjà Vu software package. Please read the following important points before you begin installation.

Be sure to install Déjà Vu onto your hard disk; you cannot run Déjà Vu from your CD-ROM drive. If you experience any problems with installation from the CD-ROM disc, remove the disc from your machine and wipe it off with a soft cloth to ensure that it is free from dust and fingerprints.

Note. If you are installing on a network server, see Installing Déjà Vu on a network (page 10).

· To install Déjà Vu on Windows 95/98 or Windows NT 4.0 or Windows 2000 workstations

1. Close all applications and turn off virus-detection and screen saver software on your computer. This frees up memory for installation and prevents possible conflicts between the Déjà Vu installer and other programs.

2. Insert the Déjà Vu CD-ROM into your CD-ROM drive.

The Déjà Vu AutoRun window should appear.
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3. Click on Install Déjà Vu. This will run Déjà Vu Setup.
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4. Click on Next to view the license agreement. Read the license agreement carefully.
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If you agree with it, click on Next. If you do not, click on Cancel.

5. Enter your name and organization, and click on Next.
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6. If you do not want to use the default destination directory that Setup specifies, you can click Browse to select a directory.
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Click on Next. If the directory does not exist, you will be asked if you want to create it; click on Yes.

7. You will now be prompted to select an installation type.
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You can select 

· Typical, to install all of the Déjà Vu components.

· Compact, to install Déjà Vu without any spell checking dictionaries.

· Custom, to install those Déjà Vu components you specify.

Select one of the options, and click on Next.

8. If you chose Custom setup, you will be shown a list of Déjà VU components. Select the components you want to install.

You must select at least Application Files in order to install Déjà Vu correctly. Select the spelling components you want to install, and click on Next.

9. If you do not want to use the default program folder (the folder which appears under the Programs section of the Start menu) that Setup specifies, you can type a new folder name, or select one of the existing folders.
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Once you have selected the folder you want, click on Next.

10. Setup will now ask you to review the installation settings.
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If any of the information is incorrect, you can click on Back to edit the information. Otherwise, click on Next to begin installing.

Setup will display a dialog indicating the installation progress.

11. Once the installation is finished, Setup may ask whether you want to reboot your system (this will happen if there were any files which Setup could not update because they were in use). It is recommended that you do reboot, so that all new files will be properly installed. If no reboot is necessary, Setup will ask you whether you want to view the README file. It is recommended that you do.
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Once you have selected the appropriate option, click on Finish to close Setup.

Déjà Vu is now installed.

Note. Before running Déjà Vu, make sure the protection dongle XE "Dongle"  is attached to the parallel port of your computer. If you have a printer connected to the back of the dongle, leave it turned on while using Déjà Vu.
Installing Déjà Vu on a network XE "Installing Déjà Vu:on a network" 
Installing Déjà Vu on a network file server and allowing users to run Déjà Vu from the server is not recommended. There are three reasons for this:

· Déjà Vu requires certain components, such as DLL files, to be present in the system directory of the machine on which it is being run. This means that if you install Déjà Vu on a network server, those components will be copied to the system directory of the server, but will not be present on the workstation from which Déjà Vu will be run, so it is possible that Déjà Vu will not work.

· There are various user settings saved in a file called Settings.mdb in the Déjà Vu installation directory. If multiple users share this directory, users’ settings will be overwritten.

· Déjà Vu will run noticeably more slowly if run from a network server.

When running the Déjà Vu installation program from a workstation, you should not select a shared network directory as the destination directory; this will result in problems similar to those described above.

The recommended procedure for using Déjà Vu on a network is to install the program on each workstation. The network administrator should then create a shared directory on a network server to place source documents, translated documents, Déjà Vu project files and Déjà Vu memory and terminology databases.

The Déjà Vu components XE "Déjà Vu components" 
Projects XE "Projects" 
When you use Déjà Vu you will normally deal with projects.

A Déjà Vu project is a computer file with a special structure that Déjà Vu can display and manage in a convenient way designed to facilitate your work.
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Typically, a project contains:

· All the text in a translation job, both source and translated text, organized in a table with several columns.

There is one column for the source text, plus one for each target language. Only one target column is visible at a time.

Each source sentence occupies one row in the table. Source text is divided into rows according to rules and exceptions you can specify.

· Formatting and other ancillary information found in the original documents.

This non-translatable information is either hidden between sentences (rows), or encapsulated in invisible, embedded codes.

A project can be built from different source documents (files): normally, all files of a given type found in a particular branch of your directory tree. For example, all HTML files in the AClient directory and its subdirectories:
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Rows in the table can be displayed in different ways:

· One file at a time.

· All the files together.

In either case, rows can be viewed in alphabetical or natural order.

The program you use to create, manage and translate projects is Déjà Vu Interactive.

Déjà Vu Interactive offers a large number of tools that will make you more productive. Some of them connect the project with the Déjà Vu memory and terminology databases.

Once the translation is finished, the project is exported to another branch in the directory tree, creating the translated versions of all the intervening source files and preserving all the formatting information.

Memory databases XE "Memory databases" 
A Déjà Vu memory database is a computer file that contains pairs of sentences (source and target) you have added to it. Each pair is tagged with information on subject, client and date/time stamp.

The information in a memory database is bilingual. This means that you will need at least one memory database for each language pair and direction.

The program you use to manage memory databases is Database Maintenance.

A memory database receives the sentence pairs you send to it when you are translating a project with Déjà Vu Interactive. It is also possible to add pairs by importing them from external databases (Excel, Access, text, TMX, Catalyst, etc.) and by aligning separate source and target text files.

Memory databases XE "Memory databases"  can be exported to different external formats.

The Database Maintenance program offers tools for compacting and repairing memory databases, and for running SQL queries and commands that will help you in maintaining your data.

Terminology databases XE "Terminology databases" 
A Déjà Vu terminology database is a computer file that contains pairs of terms (source and target) you have added to it. Each pair is associated with grammatical information, a definition field for each language, and information on subject, client and date/time stamp.

The information in a terminology database is bilingual. This means that you will need at least one terminology database for each language pair and direction.

The program you use to manage terminology databases is Terminology Maintenance.

A terminology database receives the term pairs you send to it when you are translating a project with Déjà Vu Interactive. It is also possible to add terms by importing them from external databases (Excel, Access, text, Catalyst, etc.).

Terminology databases can be exported to different external formats.

The Terminology Maintenance program offers tools for compacting and repairing terminology databases, and for running SQL queries and commands that will help you in maintaining your data.

Programs

Déjà Vu consists of six programs that perform various tasks. While it is possible to use these programs independently, you will experience a greater productivity increase by using them together.

Déjà Vu Interactive XE "Déjà Vu Interactive" 
Déjà Vu Interactive (DVI) is the program you will use to build and manage projects, to enter your translations, etc.

You can begin working with Déjà Vu using only this part of the software. It contains all the resources you need to get started.

If you have used a previous version of Déjà Vu, you can use the Database Conversion Wizard to convert your databases to the new format.

Database Maintenance XE "Database Maintenance" 
This is a workbench where you will find all the tools required for maintaining your memory databases: import/export, repairs, file alignment, manually adding or removing sentence pairs, etc.

Terminology Maintenance XE "Terminology Maintenance" 
This utility is equivalent to Database Maintenance, but works on terminology databases.

Database Conversion Wizard XE "Database Conversion Wizard" 
This is the program to use if you have older Déjà Vu memory databases that you wish to convert to the current version format.

TermWatch XE "TermWatch" 
TermWatch is a program that lets you access terminology databases from any (or almost any) Windows application. You can define key combinations that, when pressed, will look up the selected word in the terminology database and

· insert the target term into the calling application, replacing the selected text, or

· copy the target term to the clipboard, or

· present all matches in a table (as for lookups started from DVI)

All the terminology maintenance functions are accessible through TermWatch, including import/export facilities.

SGML Filter Maintenance XE "SGML Filter Maintenance" 
This tool allows you to define filters for files tagged using the SGML standard. Unlike other file formats (HTML, FrameMaker, Word, etc.) supported by Déjà Vu, SGML (Standardized General Markup Language) is not a real file format; it is a standard for tagging files, and for defining those tags. Since each customer may use a different set of tags, an SGML filter must be created with the SGML Filter Maintenance tool for each one.

Typical workflow XE "Workflow" 
The following diagram illustrates the relationship between the several Déjà Vu components and programs.

1. You might begin by creating a memory database with Database Maintenance and using the Align button (page 163) to build the initial database from existing translations.

2. Use Database Maintenance to add or remove pairs of sentences, spell-check, etc.

3. Use Terminology Maintenance to import your existing glossaries.

4. Put your source files (the files you are going to translate) in a suitable directory on your hard disk.

5. Create a DejaVu Interactive project and import the source files.

6. During the translation DejaVu Interactive will retrieve information from the databases. You can send information to the databases manually or automatically.

7. When the translation is finished, export it to create the target files. 
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Using Déjà Vu Interactive – a tutorial XE "Déjà Vu Interactive" 

 XE "Tutorial" 
Now that you have installed Déjà Vu on your computer, you are ready to begin with our tutorial.

The series of step by step procedures in this chapter goes through the process of translating the specification sheets for two fictitious printers, the ACME SpeedPrint 720 and the SpeedPrint 1440. Although the specifications are entirely made up and not very interesting, translating them will help you become acquainted with some of the features in Déjà Vu Interactive (DVI).

Organizing your files XE "Organizing your files" 
Before you begin using Déjà Vu, the first thing you must do is to organize your work and decide where you are going to store your files (source files, translated files, project files, etc.). Hence, you must create several directories (folders) that will contain:

· source files

· translated files

· project files

· memory databases

· terminology databases

How you structure these directories is a matter of personal choice and preference. The aim is to organize your work in a way that prevents you from getting lost (and losing your files) among the many files that both you and Déjà Vu create.

For the purposes of this tutorial, we recommend the following directory structure XE "Directory structure" :
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Once you have created the directory structure, you should copy the example files from the \Samples subdirectory in the Déjà Vu CD. Copy the file SP720.RTF to C:\My Projects\ACME\Sp720\Specs
, and SP1440.RTF to C:\My Projects\ACME\Sp1440\Specs.

Configuring Déjà Vu XE "Configuring Déjà Vu" 
If you work with a language that uses a non-Latin character set, such as Russian, Japanese or Hebrew, you must tell Déjà Vu which font and character set to use for the language. If the languages you work with use the Latin alphabet, you can skip this section and go on to the next one.

· To configure the fonts in Déjà Vu

1. Open Déjà Vu Interactive.

2. On the Tools menu, click on Options…
The DejaVu options window XE "Options window"  appears:
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3. Click on Fonts to display the corresponding page:
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Click on the Select language drop-down arrow and select a language.

4. Click on Font Style.

The font selection dialog appears:
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5. Select the font, style, size and script (character set) you want Déjà Vu to use when displaying text in this language. Remember to select the correct script if your language uses a non-Latin alphabet.

6. Click on OK to accept the font settings.

You should be able to see the new font in the Sample Text area of the options window.

7. Configure any other languages you use.

8. Click on OK.

Creating a project XE "Projects:creating" 
Projects are created in Déjà Vu Interactive (DVI); you also use DVI to open projects you have created previously, and to carry out most of the tasks that comprise the translation process in Déjà Vu.

· To create a project

1. Open Déjà Vu Interactive.
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2. On the File menu, click on Create project…, or click on the [image: image18.bmp] button on the tool bar.

3. Click on RTF…
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CreateProjectMenu.bmp
4. Type Sp720 and click on Save.
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5.  XE "Projects:configuration" The Project configuration window appears.
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6. Fill in the following parameters:

· For Project title, enter ACME SpeedPrint 720.

· Click on the Browse button beside the Source common directory box and select C:\My Projects\ACME\SP720.

7. Click on Languages to select the corresponding tab.
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8. Click on the Source language drop-down arrow and select English.

9. On the Available languages table, locate the language you want to translate to, and drag it to the Target languages table.

10. Click on the Select/create button beneath the Memory box under Databases for ….
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11. In the file selector, open the directory C:\MyProjects\Da​tabases. Enter the name you want for the memory database.

12. Click on Open.

A message box will appear, asking whether you want to create the memory database. Click on Yes.

13. Click on the Select/create button beneath the Terminology box, and create a terminology database in the same way.

14. Click on OK.

Importing the source text file

Once the project has been created and configured, you are ready to import the RTF file containing the specifications for the first printer model.

· To import the source text file

1. On the File menu, click on Import external files, or click on the [image: image24.bmp] button on the tool bar.

2. A window will appear, showing all the RTF files found under the Source common directory.
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3. Double click on \Specs\SP720.RTF in the Files found area (or click on Select all).

\Specs\SP720.RTF should now appear in the Files to import or reimport column.

4. Click on Go.

DVI will now perform the following tasks:

· Filter the text to make most formatting codes hidden and inaccessible.

· Replace character-formatting codes with embedded placeholders that are difficult to delete by accident.

· Split paragraphs into sentences according to the set of rules and exceptions specified in the DejaVu options
 window.

· Build the project file with all the source sentences in a column, and an empty column for the target language.

As DVI imports the RTF file, notice that it displays the text of each sentence in the status bar.

Embedded codes XE "Embedded codes" 
Once DVI has finished importing the RTF file, the DVI Project window should look like this:
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Notice the {1} symbol at the beginning of the second sentence. This is what we call an embedded code. An embedded code contains formatting information that is inside the sentence.

In this case, {1} specifies a font change. In most cases you do not need to know what the embedded code contains, as long as you place it in the correct place. For example, if a word has an embedded code on each side, we can probably assume that, in the source text, this word is marked as bold, italics, etc.

For several reasons, it is necessary to display embedded codes. It allows us, for example, to correctly place the corresponding codes in the target sentence, thereby applying the same formatting.

Translating

Now that you have seen what embedded codes are, and the important part they play in DVI, you are ready to begin translating. Naturally, you will start with the first sentence in the file.

· To select a sentence to translate

1. Locate the source sentence in the table.

If you are not at the beginning of the file, use the table scroll bar to move to the beginning, or press Ctrl+PgUp.

2. Click on the sentence in the table.

The full source sentence should appear in the source text box.
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Since the source sentence contains an embedded code at the start, the first thing to do is to copy the embedded code to the target.

· To copy an embedded code

· Press Ctrl+D.

–Or–

· Right-click on the target text box to bring up the context menu
, and click on  >Copy first code from source.
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The {1} symbol should have been copied to the target sentence. Now you can type in the translation and use Ctrl+D to copy the second code.

The second sentence consists of a product code and name, as well as a couple of embedded codes, so actually you do not need to translate it. Instead, we can just copy the source text.

· To copy the current source sentence to the current target

· Press F5.

–Or–

· Click on the [image: image29.bmp] button on the tool bar.

–Or–

· Right-click on the target text box and click on Copy source to target.
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Once you have finished the translation for a sentence, press Ctrl+DownArrow to move to the next one
.

The background of the target cell in the table will turn light gray to indicate that you have translated this sentence manually
. Notice that in the status bar, the Position indicator has gone from 2/98 to 3/98, which means that this is the third line in a project of 98. You can use this indicator as a reference of your position inside the project.
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For the third sentence, you may want to copy the source sentence to the target, and then modify it. However you do it, remember to place the correct embedded codes. If you forget to place an embedded code, Déjà Vu Interactive will paint the cell red to warn you.

On the fourth sentence you will notice that the sentence is split into two, unlike the previous ones. If you look at the RTF file, you will notice that there is a space between the colon (:) and the tab
, which is not present in the two previous lines. While we cannot correct the original RTF file, we can make sure that this does not happen in the translation. To begin with, what we want to do is to join the two lines.

· To join two sentences

1. On the table, click on the first of the two sentences.

2. On the Edit menu, click on Join sentences (or press F3), or click on the [image: image32.bmp] button on the tool bar.

The two sentences have been joined. When entering the translation, you will probably want to remove the space between the colon and the tab.
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Continue translating until you come to the sentence that reads 720 x 720 dpi;. Translate this sentence too. You will notice that the next two sentences are very similar. Naturally, we do not want to translate the same kind of thing twice, so we will use one of Déjà Vu’s most useful features: scanning for a sentence.

Before we can look for anything in the memory database, we have to add something to it. Since we want to use the current translation to save us some work, we will send this sentence pair
 to the memory database.

· To send a sentence pair to the memory database

· On the Tools menu, click on Send pair to memory database
–Or–

· Press Ctrl+F12.

–Or–

· Click on the [image: image34.bmp] button on the tool bar.

Once you have added the sentence to the memory database, press Ctrl+Down​Arrow. We are now going to scan the memory database for a sentence similar to the current one (which happens to be the sentence you just translated).

· To scan [the memory database] for a sentence

1. Click on Scan on the Tools menu (or press Ctrl+S), or click on the [image: image35.bmp] button on the tool bar.

A window appears, showing you all the matches that were found, along with the proposed translation for the sentence you were scanning for.
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2. Since there is only one match, and it is the one we want, double click on it to paste it into the translation.

Notice that Déjà Vu Interactive automatically replaces numbers.

Continue translating until you finish the project, and practice using the features we have seen so far.

Finishing the translation

Once you have finished translating, you should send all the sentence pairs in the project to the memory database. This will ensure that everything you have translated will be available for future use, and that any incorrect translations you may have sent during the course of the translation are replaced with the final ones.

· To send all the sentence pairs from the project to the memory database

1. Click on Send project to memory database on the Tools menu (or press Shift+F12), or click on the [image: image37.bmp] button on the tool bar.

The Send what? window appears.
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You have the option of sending the sentence pairs for the current language, or all the target languages in the project. Since our project only contains one target language, both options have the same effect.

2. Check the Delete all pairs previously sent from the project option.

3. Click on OK.

Since for a large project sending all the sentence pairs can be a time consuming operation, DVI displays the progress in the status bar:
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After sending the whole project to the memory database, the final step is to export the project, i.e., to generate the translated RTF file.

· To export the finished translation

1. On the File menu, click on Export finished translations…, or click on the [image: image40.bmp] button on the tool bar.

The Export what? window appears.
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2. Click on OK.

DVI will first validate all the translated sentences, checking for problems with embedded codes and other details that could cause problems in the output file.

Once the validation stage is finished, DVI will recreate the directory structure under the Source common directory we specified when configuring the project, prepending the ISO code for the language name. For example, if you were translating the file into German, the new directory would be called C:\My Projects\ACME\SP720\de_SP720.

Doubling your productivity

In the previous section you had to translate the project manually. This should not have been exceedingly difficult, but you could have done it just as well in your word processor; your work may have been made more comfortable by hiding all formatting and layout information, but that is all. We have not made any use of the translation memory features; of course, until you sent the translation to the memory database there was nothing in it that we could use. Now that you have completed your first project, there should be enough material to demonstrate some of the interesting features in Déjà Vu.

You have translated the specifications sheet for the ACME SpeedPrint 720, and we will now translate the specifications for the new SpeedPrint 1440 model—in a fraction of the time it took to translate the first sheet.

As with any other translation job, you should begin by creating a new project.

1. Follow the explanation we presented earlier in this tutorial, but select C:\ My Projects\ACME\SP1440\Specs as the Source common directory when configuring the project.

Notice that when you select the target language, Déjà Vu remembers the last memory database and terminology database you used, and offers them as default.

2. Import the RTF file in the same way as for the previous project.
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Pretranslating XE "Pretranslating" 
This time, rather than translating the file manually, we are going to let Déjà Vu carry out a pretranslation. A pretranslation involves examining the text we are about to translate and, for each sentence in it, scanning the memory database for similar sentences we have translated in the past; Déjà Vu will take the most similar sentence (whether it is an exact
 match or a fuzzy one) and insert it in the corresponding location of the translation.

· To pretranslate a project

1. On the Tools menu, click on Pretranslate… (or press Ctrl+R), or click on the [image: image43.bmp] button on the tool bar.

The Pretranslate options window appears.
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2. Set the different options as shown above and click on OK.

Since for a large project pretranslating can be a time consuming operation, DVI displays the progress in the status bar.
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Voilà! The pretranslation is finished, and Déjà Vu has done almost all of the work for you.
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You will notice that most of the target cells are painted either green or magenta. In the same way it painted target cells red when there was a problem with embedded codes, DVI paints a cell green when it has inserted an exact match, magenta when it has inserted a fuzzy match, or dark magenta when it has had to renumber codes or digits.

Even if Pretranslate inserts an exact match, it is good practice to check the translation for any mistakes (you might have translated it wrong in the past!). Naturally, you should check and edit all the fuzzy (magenta) matches; remember to press Ctrl+DownArrow after you translate each one.

Assembling from pieces XE "Assemble from portions" 
If you look at the sentences that Pretranslate has left empty, you will see that almost all of them are completely new to DVI, i.e., there is nothing similar to them in the memory database. There are also several sentences that consist almost entirely of figures and acronyms. We will use the Assemble feature, one of the most powerful and versatile features in Déjà Vu, to try to translate these.

Let’s repeat the pretranslation, but this time we will let Déjà Vu translate, not just complete sentences, but also smaller portions, and if necessary word by word.

· To pretranslate with ‘Assemble from portions’ enabled

1. On the Tools menu, click on Pretranslate… (or press Ctrl+R), or click on the [image: image48.bmp] button on the tool bar.

The Pretranslate options window appears.
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2. Set the different options as shown above:

Check the Assemble from portions option.

Check the Insert source text for failed portions option. This will make Déjà Vu insert acronyms and other unknown words into the target as they appear in the source text.

3. Click on OK.
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You will find that the first three translations inserted by Assemble (all marked in dark blue) are probably not too useful. However, the fourth, 45 dB(A) (ISO 7779), contains only figures, single letters and acronyms, so Assemble has generated a translation. If you move further on, you will see that, where plain Pretranslate was unable to translate Support by e-mail, Assemble has succeeded partially. This is because plain Pretranslate only considers the sentence as a whole, while Assemble goes down to the word level.

After using both varieties of Pretranslate, with and without Assemble, you should have had to translate or edit only a few sentences.

Note. We have asked you to pretranslate the document in two stages in order to illustrate the effects of Assemble. In real life jobs you will probably run Pretranslate with Assemble enabled, but this may depend on the nature of your source documents and the material already available in the databases. There will be situations in which you don’t want DVI to retrieve fuzzy matches for whole sentences; this is achieved by checking the Accept only exact matches when scanning on the Pretranslate options window.
Charging your client XE "Word count" 
If this were a real job, you would probably want to count the number of words and characters you had translated, in order to charge your client accordingly; nothing could be simpler in DVI.

· To count the words and characters in the project

1. On the Tools menu, click on Count words and characters.

The Word and character count window should appear.
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You will notice that there are options that allow you to generate a very detailed word count, listing different types of matches separately. This will prove useful when assessing the progress of a translation.

2. If you want to save the output of the word count to a text file, click on Save and select a file name.

That’s all folks

You can send the project to the memory database and export the translation if you want to see the results.

By now, you should be familiar with the Déjà Vu Interactive environment, and ready to begin translating real files on your own.

Déjà Vu Interactive XE "Déjà Vu Interactive" 
Déjà Vu Interactive (DVI) is the program you will use for your daily translation work. As you learned in the tutorial, DVI is the tool you use to create, manage and translate projects. In the tutorial, we saw a number of features that make translating an easier task. This chapter explains those features in depth, as well as a large number of others which were not covered in the tutorial.

The project window XE "Project window" 
When you open DVI, you are presented with the Project window:
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Going from top to bottom, you will find:

·  XE "Menu bar" The menu bar.

As in most Windows applications, almost all of Déjà Vu Interactive’s functions are accessible through the menu bar.
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However, it is good practice to learn the keyboard shortcuts for the DVI functions you use most often, since this will let you work faster and more efficiently. You will find the keyboard shortcut for each function beside the function’s name on the menu.
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For a complete list of keyboard shortcuts in DVI, see the appendix on keyboard shortcuts (page 198).

·  XE "Tool bar" The tool bar.

The tool bar contains buttons that provide shortcuts to the most commonly used DVI functions.
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Tools on the tool bar have an associated ‘tool tip’. If you leave the mouse pointer on a tool for more than one second or so, a small caption will be displayed that indicates what the tool is for.

· A row with four boxes: text locator, file selector, target language selector and rows selector.
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From right to left, you will find:

· The text locator. XE "Text locator" 
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When you display the sentences in alphabetical order (by pressing [image: image59.bmp]), you can use the text locator to quickly jump to a different place. As you type into the text locator, DVI will reposition to the first sentence that begins with the letters you have written so far.

If you are working in natural order, you can enter a record number.

This action is artificially delayed so that you will have time to type in a few letters before the repositioning occurs.

· The file selector. XE "File selector" 
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You can work on either one specific source document at a time, or on all the documents at the same time. You can also select a special document, called the Lexicon for this project, which contains all the source language words present in the project.

· The target language selector. XE "Target language selector" 
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If you selected more than one target language when you created the current project, you can choose which target language is displayed on the right-hand side of the table.

· The rows selector. XE "Rows selector" 
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You can choose to display only certain kinds of rows, e.g., exact matches, fuzzy matches, pending rows, etc.

· The scrolling table, with the list of sentences in the current file. XE "Scrolling table" 
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You can use this list to navigate through the file, select sentences, etc.

· The complete source and target text for the row currently selected on the table.

[image: image64.png][ProductiAccessory Part Numbers Céuigo de productojaccesorio:

SpecstSPIAD a2 [251 [ape [0 s 311729 [i7i01 |





The target text box is where you enter all your translations.

· The status bar XE "Status bar" .
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The status bar displays information about the current user, the position in the project and in the current row, and about the current status of DVI.

There are also four little boxes, AAs, ASr, APr, and ASd, which you can double-click to activate and deactivate AutoAssemble, AutoSearch, AutoPropagate and AutoSend.

Rearranging the window

 XE "Splitter bar" The table that displays the source and target sentences is separated from the source and target text boxes by a thin line called a splitter bar
. You can move this bar up and down by dragging it, thus resizing the table and the text boxes. If the text boxes are too small to display an entire sentence, or if you simply feel like making them larger, then drag the splitter bar up.
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You can also stack the source and target text boxes vertically rather than horizontally by selecting the Split text area horizontally option in the Options menu. XE "Split text area horizontally" 
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If you want to see more than one line of text on the table, you can change the row height by dragging any of the lines that separate rows on the record selector area.
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Row height is reset to a value appropriate for the fonts used whenever you select a different language, or when you restart the program.

If you enable AutoSearch, you can ask DVI to rearrange the windows by opening the Window menu and clicking on Rearrange windows.

Finding your way around the project XE "Navigation" 
As we saw in the introduction to DVI, you can navigate through the project by using the table’s scrollbar or the following keystrokes:

· Ctrl+PgDn to go to the end of the file.

You can also right-click on the table and select Jump to beginning from the context menu.

· Ctrl+PgUp to go to the beginning of the file.

You can also right-click on the table and select Jump to end from the context menu.

· Ctrl+DownArrow to go to the next sentence.

· If AutoSend is enabled, the sentence pair is sent to the memory database.

· If AutoAssemble is enabled, DVI assembles a translation for the next row.

· If AutoPropagate is enabled, the translation is propagated to sentences with equal source text.

· Alt+DownArrow to go to the next unstranslated sentence. AutoSend, AutoAssemble and AutoPropagate are launched if enabled.

· Ctrl+UpArrow to go to the previous sentence.

· Alt+UpArrow to go to the previous unstranslated sentence.

· Alt+LeftArrow to go to the previous sentence without triggering any Auto… effects and without changing row status.

· Alt+RightArrow to go to the next sentence without triggering any Auto… effects and without changing row status.

Selecting a different file in the project

If you work on a project with multiple files, you may want to view a single file, rather than a concatenation of all the files.

· To change the currently displayed file

1. Click on the file selector dropdown list.
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 XE "File selector" 
2. You have the option of selecting,

· All files

This displays all the documents in the project, and is selected by default.

· Lexicon for this project.

· Individual files in the project.

You will see the name of each of the files you imported into the project.

3. Select a file name to view only that file.

Note. When you close DVI, it remembers not only the last project you were working on, but also the file in the project on which you were working. When you open DVI, it will automatically open the last project and display the last file you were using.

Selecting a different target language

If you created a project with more than one target language, then you can also change the currently displayed target language.

· To change the currently displayed target language

1. Click on the target language selector dropdown list. 
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 XE "Target language selector" 
2. Select the name of the language you want to display.

Changing the order in which sentences are displayed

By default, sentences are shown in the order in which they were found in the imported documents; this is what we call the ‘natural’ order, and is the one you will use most frequently, as it allows you to see how each particular sentence fits into the flow of the document.

You can, however, switch between natural order and alphabetical order.

· To change the sentence sorting XE "Sorting" 
· To sort alphabetically, click on the [image: image71.bmp] button on the tool bar

–Or–

· To sort naturally, click on the [image: image72.bmp] button on the tool bar 

Note. When you switch from one mode to the other, DVI will keep the same current record.

 XE "Text locator" While in alphabetical order you can use the text locator to quickly jump to a different place.

· To locate a sentence XE "Text locator" 
· If your sentences are sorted alphabetically, type the first letters of the sentence you want to locate into the text locator.
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As you type into the text locator, DVI will reposition to the first record that begins with the letters you have written so far. This action is artificially delayed so that you will have time to type in a few letters before the repositioning occurs.

· If the display is sorted in natural order, type the number of the record to which you want to jump.

Bookmarking a sentence XE "Bookmarking a sentence" 
At any time you can mark the current record with a bookmark. This will enable you to easily locate it afterwards.

· To bookmark a sentence

· On the Edit menu, click on Set bookmark.

–Or–

· Press Ctrl+B.

Later on, whatever the sorting mode and your whereabouts in the project, you can return to the bookmarked record.

· To go to the bookmark

· On the Edit menu, click on Go to bookmark.

–Or–

· Press Ctrl+G.

Selecting rows XE "Selecting rows" 
You will have probably just asked yourself how you were going to manage to mark or unmark a whole set of rows. Doing it one by one is rather tedious, and the point of Déjà Vu is to speed you up, not to slow you down. Therefore, as you can imagine, you can select several rows at a time.

If you look at the table, you will notice that leftmost gray column contains the ‘rows selectors’.

· To select a single row, click on its rows selector.

· To add further rows to the selection, or to remove individual rows from the selection, hold down the CTRL key and click on the desired rows selector.

· To add a number of consecutive rows to the current selection, hold down the SHIFT key and drag the mouse over the desired rows’ selectors.

· To deselect all rows, click on any source or target cell.

If you are an experienced Windows user, you will realize that this is the standard way of selecting elements in tables, and that you have seen this before; you will find that many features in Déjà Vu work just like that: exactly how you would expect them to.

Filtering the project – the easy way XE "Filtering the project:the easy way" 
You can display only those rows that contain a certain word or phrase, either in source or in target. This will allow you to concentrate on a subset of your project if, for example, you are having a problem with that particular word or phrase.

·  XE "Filter on selection" To filter the project on a word or phrase

1. Select the desired text in the source or target box.

2. Right-click on the pertinent box and click on Filter on selection.

The target cell will be painted in cyan.

· To clear the filter

1. Right-click on the source box or the target box and click on Unfilter.

Filtering the project with SQL queries XE "Filtering the project:with SQL queries " 

 XE "SQL" 
For more complex filtering you can use SQL queries. DejaVu Interactive will display only those records that meet the criteria you specify, and the criteria can be as elaborate as necessary.

· To run an SQL query

1. On the Tools menu, open the SQL submenu and click on Select.

2. Enter the text of the query.

For those familiar with SQL, the text to enter here is the part that comes after the WHERE clause in SELECT queries. Use the ‘Available fields’ list to see which fields you can mention in your query and to minimize the risk of spelling errors.

If you are not sure how to translate something XE "Marking rows as pending" 
As a translator, you will have often come upon sentences or expressions that are very difficult to translate. The more you think about them, the harder they become to translate. What you would like to do is to forget about it for a while, continue translating, and come back to it when your mind is fresh. But you are probably worried that you won’t remember it later, and the sentence will remain untranslated—and, what’s worse, this will show up in the finished translation.

With Déjà Vu Interactive, you can forget about these problems. When you come upon a sentence that you do not feel like translating at that moment, you can simply mark it as pending.

· To mark a row as pending

1. Select the sentence you want to mark as pending.

2. Right-click on the sentence table and click on Mark row as pending.
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The target cell will be painted in cyan.

· To remove the pending mark

1. Select the sentence you want to mark as normal (non-pending).

2. Right-click on the sentence table and click on Unpaint.

–Or–

Press Ctrl+U.

If you don’t want a certain sentence to end up in the memory database

· To prevent a row from being sent to the memory database

1. Select the desired row.

2. Right-click on the sentence table and click on Prevent row from being sent to MDB.

–Or–

Press Ctrl+Y.

A ‘no entry’ symbol will appear between the two columns.
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· To allow a row to be sent to the memory database

1. Select the desired row.

2. Right-click on the sentence table and click on Allow row to be sent to MDB.

–Or–

Press Ctrl+Y.

The ‘no entry’ symbol will disappear.

Déjà Vu Interactive’s color codes XE "Color codes" 
As you will have noticed, target cells usually have a white background. This can change to different colors that help you in identifying the status of each target cell.

· When you enter and leave a cell, its background color will change either to (a) light gray to indicate that you have been working on this cell and presumably have finished translating it, or to (b) red to indicate that there is something amiss with the embedded codes in that cell (for example, missing or not properly closed codes).

· When you pretranslate a document, target cells will be painted (a) green for exact matches; (b) dark green for rows for which multiple exact matches have been found; (c) magenta for fuzzy matches; (d) dark magenta for almost exact matches, i.e., matches for which it has been necessary to renumber codes or numerals.

· When you lock a row
, the target cell will be painted yellow.

· When you mark a row as pending, the target cell will be painted cyan.

· When you use the AutoPropagate
 function, autopropagated rows will have their target cells painted light green.

Note. You can unpaint a row or a selection by right-clicking on the sentence list and selecting Unpaint, or by pressing Ctrl+U. XE "Unpaint" 
Color coding can prove invaluable when checking the results of a pretranslation, or when having the last look at a project before you export it.

To make this even easier, you can use the rows selector to tell DVI to display only rows of a certain type.

· To change the type of row currently displayed

1. Click on the rows selector dropdown list. XE "Rows selector" 
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2. Select the type of row you want to display.

Configuring Déjà Vu XE "Configuring Déjà Vu" 

 XE "Options" 
This section describes how to fine-tune the way Déjà Vu works. Although the default options are adequate in most cases, there are certain settings you may want to configure:

· Select options that control how Déjà Vu Interactive works.

· Manage AutoText entries.

· Select options that control how the information is stored in memory databases and how it is retrieved therefrom.

· Define sentence separators.

These are characters that mark the end of one sentence and the beginning of the next; they are set on a per language basis.

· Define character attributes.

You must tell Déjà Vu whether a character is a letter, a digit, a word separator, etc. This will be used by Déjà Vu when splitting sentences into words. These too are set on a per language basis.

· Set the font for each language you use.

This is especially important if you work with languages that use a non-Latin character set. For each language you use, you can set the font, size and character set (e.g., Greek, Turkish, Japanese Shift-JIS) to use when displaying text in that language.

· Add subjects and/or clients.

Déjà Vu allows you to specify a subject and a client for each project you work on. This information is sent to the memory database with each translated sentence, and is used for refining Déjà Vu scans, pretranslations, and terminology scans.

· To configure Déjà Vu

· On the Tools menu, click on Options…
The DejaVu options window appears.

General options XE "Options:general" 
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Assemble XE "Assemble from portions" 
· Enable AutoAssemble. Asks DVI to perform an Assemble operation every time you move from one row to the next by pressing Ctrl+DownArrow (or to the next untranslated row by pressing Alt+DownArrow). XE "AutoAssemble" 
· First scan for whole sentence. Before assembling, try to find a match for the complete sentence in the memory database.
· Accept only exact matches when scanning. When scanning before assembling, reject fuzzy matches (probably because assembling from portions is expected to yield better results).
· Insert source text for failed portions. This will make Déjà Vu insert unknown words into the target as they appear in the source text.
AutoSearch

·  XE "AutoSearch" Enable AutoSearch. Lets DVI display the AutoSearch windows.
· Display portions from memory database. Controls whether or not the Portions found window (page 96) will display also matches found in the memory database, and whether or not the memory database will be used when performing terminology checks.
· Remove embedded codes from portions. Removes any embedded codes present in text retrieved from the databases before displaying it in the Portions found window (page 96).
Conversions XE "Conversions" 
·  XE "Leading/trailing symbols" Control leading/trailing symbols. Lets DVI add or remove spaces and symbols at the beginning or end of retrieved target text to match those present in source text (page 84).
· Allow decimal conversions. Lets DVI convert decimal symbols and thousands symbols in target text (page 84). XE "Decimal conversions" 
· Allow case conversions. Lets DVI apply upper/lowercase conversions to target text in order to match capitalization in source text (page 84). XE "Case conversions" 
On Ctrl+DownArrow XE "Ctrl+DownArrow" 
The options in this group control certain automatic operations that can be triggered when you move from the current row to the next by pressing Ctrl+DownArrow (or to the next untranslated row by pressing Alt+Down​Arrow):

· AutoPropagate. If enabled, DVI will automatically propagate the current translation (page 129). XE "AutoPropagate" 
· AutoSend to memory database. If enabled, DVI will automatically send the current translation to the memory database (page 113). XE "AutoSend" 
View

· Display embedded codes. Controls whether or not embedded codes are visible (page 79).
· Split text area horizontally. Controls how source and target boxes are displayed on the DVI main window (page 44). XE "Split text area horizontally" 
· Terse display on terminology matches. When this option is set, terminology matches are displayed without grammatical, subject and client information (page 91).
Terminology lookups

· Enable fuzzy terminology matching. Lets DVI do word stemming when searching the terminology database in Assemble, Lookup and AutoSearch operations. XE "Fuzzy terminology matching" 
Terminology checks XE "Terminology checks" 

 XE "Checking terminology" 

 XE "Checking numerals" 
· Check also numerals. Lets DVI check for mismatches in numerals between source and target when performing terminology checks (see page 100). XE "Fuzzy terminology matching" 
Organizing AutoText entries XE "AutoText" 

 XE "Options:AutoText" 
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· To begin organizing your AutoText entries

1. Click on the AutoText tab. XE "AutoText" 
2. Select the desired language.

AutoText as you type. If you activate this option, DVI will expand each entry as soon as you type it. If not, DVI waits until you press F8 after typing the entry. XE "AutoText:as you type" 
There are two kinds of AutoText entries: global and project-specific. Global entries are always available. Project-specific entries are available when the corresponding project is open. To select which kind or entries you want to organize, click on either Global entries or Current project entries.

· To create an AutoText entry

1. Select whether you want to create a global or a project entry.

2. Type the abbreviation, or the text you want DVI to autocorrect, in the ‘Token:’ slot.

3. Type the replacement text in the ‘Replace with:’ slot.

4. Click on Add new entry.

· To modify an AutoText entry

1. Click on the desired entry on the table to select it.

2. Enter the new replacement text in the ‘Replace with:’ slot.

3. Click on Modify entry.

· To delete an AutoText entry

1. Click on the desired entry on the table to select it.

2. Click on Delete entry.

· To copy AutoText entries from one project to another

1. Open project A (the project you want to copy entries from).

2. On the Tools menu, click on Options…
3. Click on the AutoText tab.

4. Select Current project’s entries.

5. Click on Copy all to clipboard.

6. Click on OK to exit the options window.

7. Close project A and open project B (the project you want to copies the entries to).

8. On the Tools menu, click on Options…
9. Click on the AutoText tab.

10. Select Current project’s entries.

11. Click on Merge from clipboard.

12. Click on OK to exit the options window.

·  XE "AutoText:import from Word" To import AutoCorrect entries from MS Word

1. Click the Import from Word button.

Database performance XE "Options:database" 
With this tab you can set, separately for each source language, the following values:
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· The default value of Fuzziness XE "Fuzziness" .

This parameter controls how strict Déjà Vu will be when doing scans or pretranslating; the lower the value, fewer matches will be displayed, since only higher quality matches will be selected. Use the slider to select a value from 0 (exact matches only) to 9. You can change this value at any time, if you feel Déjà Vu is displaying too many or too few matches.

· The value for Minimum number of words in a sentence XE "Minimum number of words in a sentence" .

Sentences with fewer words won’t be stored to Déjà Vu databases. Use the slider to select a value from 1 to 9. This is useful to prevent short (and rather useless) sentences from taking up space in the memory database
.

· The value for Minimum number of characters in a word XE "Minimum number of characters in a word" .

Words with fewer characters will be ignored by Déjà Vu when searching for a sentence. Use the slider to select a value from 1 to 9. For example, English words such as “and,” “but,” “or,” etc. can be omitted since they are of little value when searching for matches.

· All other conditions being the same …

When Déjà Vu finds several possible matches, one will considered better than another if its subject and/or client information is the same as that specified for the current project. However, if all the matches found share the same client/subject data, Déjà Vu will select either the newest or the oldest. You can decide which by setting one of the options: Older matches are preferred or Newer matches are preferred.
Sentence delimiters XE "Sentence delimiters" 

 XE "Options:sentence delimiters" 
The Sentence delimiters tab lets you specify (separately for each language):

· Which characters belong to each of the five possible groups (digits, lower case letters, upper case letters, ‘anycase’ letters, and symbols).

· The rules for splitting text into sentences.

· The exceptions to those rules.
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A splitting rule specifies what is to be found on each side of the splitting point. For example, one of the default rules, .^w , sets a splitting point after a full stop followed by white space, whatever comes thereafter.

The exception to this rule says, “don’t split if a lowercase letter comes after the splitting point.”

When writing rules and exceptions you can use the following symbols:

	Symbol
	Meaning

	^w
	white space

	^#
	a digit

	^$
	a letter (uppercase, lowercase or anycase)

	^a
	a lowercase letter

	^A
	an uppercase letter

	^?
	a character

	^^
	the caret (^) itself


· To begin organizing your sentence delimiters

1. Click on the Sentence delimiters XE "Sentence delimiters"  tab.

2. Select the desired language.

· To add a rule or an exception

1. Type the desired symbols in the ‘Before split’ and ‘After split’ cells.
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While you are typing, you can right-click and select any of the special symbols from a menu.

2. Click on Add.

· To remove a rule or exception

1. Click on the desired row on the table to select it.

2. Click on Delete.

Characters XE "Characters" 

 XE "Options:characters" 
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 XE "Lowercase" 

 XE "Upercase" 

 XE "Anycase" 

 XE "Symbols" 

 XE "Digits" The Characters tab lets you specify, separately for each language, which characters are to be considered digits, letters (lowercase, uppercase or ambiguous case) or symbols.

· To define a character

1. Right-click on the desired character.

2. Select one of the options from the menu.

Fonts XE "Fonts" 

 XE "Options:fonts" 
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The Fonts tab lets you specify, separately for each language, the font name and a complete set of font attributes used by Déjà Vu to display that language.

· To set the font for a language

1. Click on the Fonts tab.

2. Select the desired language.

3. Press the Font Style button to open a font selector. For languages that use special character sets, you should make sure that you select the appropriate character set XE "Character set"  (script) in the font selection window.
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Subjects XE "Subjects" 

 XE "Options:subjects" 
The Subjects tab contains a table in which you can add, delete, and modify subject codes and descriptions.
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· To begin organizing your subjects

· Click on the Subjects tab.

· To add a subject

1. Type the subject code in the ‘Code:’ slot.

2. Type the subject description in the ‘Description:’ slot.

3. Click on Add subject.

· To modify a subject description

1. Click on the desired row on the table to select it.

2. Enter the new description text in the ‘Description:’ slot.

3. Click on Modify subject.

· To delete a subject

1. Click on the desired row on the table to select it.

2. Click on Delete subject.

· To delete a group of subjects in a single operation

1. Select the rows you want to remove:

· To select a range of contiguous rows, click on the row selector (leftmost column) of the first row in the range; then hold down the Shift key and click on the row selector of the last row in the range.  If necessary, the vertical scroll bar can be used to bring additional rows into view.

· To add further rows to the selection, or to remove individual rows from the selection, hold down the Ctrl key and click on the desired row selector.

· To de-select all rows, click on any code or description cell.

2. Click on Delete subject.
· To quickly locate a subject

1. Click on the Find subject box.

2. Enter the first couple of digits in the subject code, or the first characters in a word contained in the subject description.

Clients XE "Clients" 

 XE "Options:clients" 
The Clients tab contains a table with the list of your clients. Each client has a code and a name.
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To add, delete, modify or locate clients, do as explained for the Subjects tab.

Working with projects XE "Projects:working with" 
When you use Déjà Vu you will normally deal with projects. A Déjà Vu project is a computer file with a special structure that Déjà Vu can display and manage in a convenient way designed to facilitate your work.

Creating, opening and closing projects

To work with DVI, you must start by opening or creating a project. Déjà Vu automatically stores the translation you enter whenever you move to another sentence. Therefore, you do not have to worry about saving the project yourself.

Note. You will rarely need to open a project manually, though, since DVI automatically opens the last project you were working on.

· To create a project

1. On the File menu, click on Create project...
–Or–

Click on the [image: image87.bmp] button on the tool bar.

2. Select the format of your documents.
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3. Specify a location and filename for your new project.
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The .dvf extension will be added automatically.

4. Press ( or click on Save.

After creating a project, the Project configuration window will appear automatically. Although you must configure a project before you start working with it, you can change any options later on.

·  XE "Projects:configuration" \t "See" To configure a project

1. On the Tools menu, click on Configure current project...
–Or–

Click on the [image: image90.bmp] button on the tool bar.

The Project configuration window will appear:

[image: image91.png]it ptansts | Larguages |

P tle PrectD s 716782
[ECHE SpecdPin 720

Cient

Subit

[ |

Soutcs common diect
[ExHy ProeasWONEVGF 720 B

Outut dectoy for vanled e
[EVyProft AEWE\GP72E, Browse

Source fle extensions

I Prevent sertence segmentation
i

T~ Ignore hidden text

These notes are nottranslatable: [+ # @ & Restore defauls I~ Secuy enabled

oK





2. Specify the project title.

3. If pertinent, select a subject for the project
.

This information will be used for refining Déjà Vu scans, pretranslations, and terminology scans.

4. Enter, or select with the Browse button, the directory that contains all the documents in the project (Source common directory XE "Source common directory" ).

DVI will later search that directory and all of its subdirectories when looking for source files.

5. Enter the path that will contain the translated documents (Output directory XE "Output directory" ).

6.  XE "File extension" Specify the file extension (s) for the source documents in the project; e.g., rtf for rich text format, htm or html for HTML files, etc. If you specify several extensions, enter them separated by a space; e.g., rc dlg for RC files
.

DVI will later export to that directory, creating subdirectories named after the ISO code for each target language. A typical situation could be:

· Source common directory: C:\WebProjects\AClient
· Output directory: C:\WebProjects
	Initial directory tree
	After exporting Spanish and Italian
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7. Click on the Languages tab.

8. Click on the down arrow beside the source language box. A list of languages will appear; select the source language for the project.

9. To add a target language, find the language in the Available languages XE "Available languages"  table and drag
 it to the Target languages XE "Target languages"  table.
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To remove a language from the Target languages list, simply drag it to the rubbish bin at the bottom of the window.

10. For each selected target language, specify:

· the memory database to be used with this source/target combination.

Click on Select/create to open a file selector where you can locate the memory database.

· the terminology database to be used with this source/target combination.

Click on Select/create to open a file selector where you can locate the terminology database.

· if the language is English, Portuguese or Norwegian, a button will appear to the right of the language name.

Click on this button and select the dictionary you want to use for spell checking.
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11. Click on OK.

· To open a project

1. On the File menu, click on Open project…
–Or–

Press Ctrl+O.

–Or–

Click on the [image: image96.bmp] button on the tool bar.

2. In the file selector window that appears, select the project you want to open and click on Open.
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Note that when you open Déjà Vu Interactive, it loads the last project you have worked on, so if you want to change to another project, you must first close the current project.

· To close a project

· On the File menu, click on Close current project.

–Or–

· Click on the [image: image98.bmp] button on the tool bar.

Importing project files XE "Projects:importing files" 
Once a project has been created, the next step is to import the files you want to include.

· To import source files

1. On the File menu, click on Import [the format of your source text] files…

–Or–

Click on the [image: image99.bmp] button on the tool bar.

DVI will look in the Source common directory (see To create a project, step 4) and any subdirectories for all files with the extensions specified when you created the project (see To create a project, step 6).

2. A window will appear, showing all files found.
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This window is divided into three areas: Files found, File to import or reimport and Files already imported.

3. In the Files found list, select the files you want to use and click on Select.

4. Click on Go to begin importing the files. DVI will:

· Filter the text to make most formatting codes hidden and inaccessible.

· Replace character-formatting codes with embedded placeholders that are difficult to delete by accident.

· Split paragraphs into sentences according to sets of rules and exceptions you can set in the DejaVu options window.

· Build the project file with all the source sentences in a column, and one empty column for each target language.

Removing files from a project XE "Projects:removing files" 
In some cases, e.g. if you added a file incorrectly, you may want to remove files you have imported into a project.

· To remove files from the project

1. On the File menu, click on Remove files…
A window will appear, showing all the files in the project.
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2. In the Files already imported list, select the files you want to remove and click on Select.

3. Click on Go.

DVI will ask for confirmation.
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4. Click on Yes.

Exporting project files XE "Projects:exporting translations" 
Once you have finished translating the project, you should export the finished translation. You can export either the current file or all the files in the project.

· To export the current file

1. On the File menu, click on Export finished translation…
–Or–

Click on the [image: image103.bmp] button on the tool bar.

2. The Export what? window appears.
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3. Select Current file.

4. If you want to export all the languages in the project, select All target languages.

Otherwise, select the current language.

· To export all the files in the project

1. On the File menu, click on Export finished translation…
–Or–

Click on the [image: image105.bmp] button on the tool bar.

2. The Export what? window appears.
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3. Select All files.

4. If you want to export all the languages in the project, select All target languages.

Otherwise, select the current language.

DVI will write all the target files to subdirectories of the Output directory you specified when you configured the project.

To view the final text, you will have to use the program that corresponds to the format of the final document (Word, an HTML browser or editor, FrameMaker, etc.). You should then make any final adjustments that may be necessary.

Splitting and joining sentences

After importing, it is possible that you may find that a sentence has been incorrectly split
. DVI splits the source text into sentences using the rules and exceptions you set for the project’s source language. However, even with the most carefully built set of rules and exceptions, there may be errors in the way in which DVI breaks text into sentences. You can correct such errors by:

· Manually splitting a sentence at a certain point.

· Manually joining two sentences together. 

· To split a sentence XE "Splitting sentences" 
1. Select the sentence you want to split, and click on the source text box.

2. Move the insertion caret to the position where you want to split the sentence.

3. On the Edit menu, click on Split source sentence.

–Or–

Press F4.

–Or–

Click the [image: image107.bmp] button on the toolbar.

· To join two sentences XE "Joining sentences" 
1. On the scrolling table, select on the first of the two sentences you want to join.

2. On the Edit menu, click on Join sentences.

–Or–

Press F3.

–Or–

Click the [image: image108.bmp] button on the toolbar.

Compacting projects

When you work with large projects and remove files or languages, you may find that your project files do not decrease in size. To minimize the time it takes to carry out such operations, Déjà Vu will not always completely remove these elements.

If you notice that your project file grows exceedingly large, it is a good idea to compact the file. You should make sure that you have enough space (in the worst case, the size of the uncompacted project file) on one of your hard drives
.

· To compact a project XE "Projects:compacting" 
1. On the Tools menu, open the File utilities submenu and click on Compact project.

2. In the file selector window that appears, select the project you want to compact and click on Open.

Repairing projects XE "Projects:repairing" 
During time consuming processes, such as importing large projects, a failure in your computer may leave the project file corrupt. In most cases, it is possible to repair the project file so that no data is lost. In other cases, however, repairing may not be possible. You should therefore make sure you always have recent backup copies of your project files.

If you are going to repair a project, you should make sure that you have enough free space (roughly the size of the corrupt database) on one of your hard drives.

· To repair a project

1. On the Tools menu, open the File utilities submenu and click on Repair project.

2. In the file selector window that appears, select the project you want to repair and click on Open.

Project maintenance with SQL commands XE "SQL" 

 XE "Projects:maintenance with SQL commands" 
You can execute SQL commands to perform maintenance operations on your project. If is possible to run any SQL commands, even those that can destroy your project or your translation. You must, therefore, be very careful when using this resource. If in doubt, please write to support@atril.com and describe what you need to achieve.

· To run an SQL command

1. On the Tools menu, open the SQL submenu and click on Execute.

2. Enter the text of the command.

Use the ‘Available fields’ list to see which fields you can mention in your command and to minimize the risk of spelling errors.

Working with embedded codes XE "Embedded codes" 
When you work with file types other than plain text, DVI only displays translatable text — everything else is hidden. However, in the case of formats such as RTF, FrameMaker, or Interleaf, there is often formatting information embedded in the sentence, such as whether a particular word is in bold. Since DVI cannot automatically decide what formatting belongs to which word, this formatting information cannot be completely hidden. Instead, it is displayed as an embedded code. If you have created a DVI project for, say, RTF, you will have probably noticed that many sentences contain symbols such as {14} or {835}; these are embedded codes.
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For several reasons, it is necessary to display embedded codes. It allows you, for example, to correctly place the corresponding codes in the target sentence, thereby applying the same formatting. For example, if you have a source sentence like this,

Click on the {35}Next{36} button.

when you translate it you should place the embedded codes like this,

Haga clic sobre el botón de {35}Siguiente{36}.

In almost every case, you do not need to worry about what {35} and {36} really contain; nevertheless, it is clear that, whatever effect they have, they must be placed before and after the word Siguiente (which is translation for Next).

· To hide and display embedded codes

· On the Options menu, click on Codes visible.

–Or–

· Press F9.

It is not possible to enter or modify a translation while embedded codes are hidden.

Modifying embedded codes

Embedded codes are protected in such a way that it is difficult to tamper with them. If you were to delete even only one, the export function might not be able to reconstruct a valid DTP file. It is possible, however, to modify
 their contents.

· To modify the contents of an embedded code

1. Click anywhere on the code.

2. Right-click to bring up the context menu, and click on Display code.

3. A window appears, showing the contents of the embedded code:
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4. Enter your changes on the right hand side box.

5. Click on Confirm changes.

You should only change the contents of embedded codes when absolutely necessary. For example, when the code represents a hard hyphen that is not required in the translated text.

Deleting embedded codes

In some cases, you may want to temporarily delete the embedded codes from the target sentence.

· To delete a single embedded code

1. Click anywhere on the code.

2. Right-click to bring up the context menu, and click on Delete code.

–Or–

1. Select the entire code (double clicking on a code will select it).

2. Press Ctrl+X.

You will notice that when you delete an embedded code, the target cell turns red to indicate that there is a problem with the codes.
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· To delete all embedded codes in a sentence

1. Select the sentence you want.

2. Right-click on the target text box to bring up the context menu, and click on Delete all codes.

You can also select Delete codes and text to delete the whole sentence).

Copying and moving embedded codes

When you are translating a sentence that contains embedded codes, you must make sure that the target sentence contains the same embedded codes, or DVI will not be able to export the project files properly.

· To automatically copy the next embedded code

· Right-click on the target box, and click on > Copy [first/next] code from source.
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–Or–

· Press Ctrl+D.

DVI will insert the first embedded code which is in the current source sentence and not already in the target sentence.

· To automatically copy all embedded codes

· Right-click on the target box, and click on >> Copy all codes from source.

–Or–

· Press Ctrl+F5.

–Or–

· Hold down the Ctrl key and click on the [image: image113.bmp] button on the tool bar.

Embedded codes found in the current source sentence will be inserted to the left of the current target sentence. (If you hold down the Shift key at the same time, the operation will affect all the visible rows.)

· To manually copy an embedded code from source to target

1. Double-click on the desired code in the source sentence.

2. Drag the selected code to the target box, hold down the Ctrl key (otherwise the code will be moved rather than copied) and release the mouse button at the position where you want the code to be inserted.

[image: image114.png]EWe766256: (2)ACME SpeedPrint 766256 ACME SpeedPrint 1440
Tas0 .

a2 251 [Apr [250 s 341728 [27i01 |





· To move an embedded code in the target box:

1. Double-click on the code you want to move.

2. Use drag and drop to move the selected code to the desired position.
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Translation functions

Although DVI makes manual translation much easier than on a word processor or a DTP program by hiding formatting and layout information and providing you with powerful editing functions, it can do much more. If you followed the tutorial, you will have seen a few of its powerful features in action; we will now explain them all in detail.

Automatic conversions XE "Automatic conversions" 
Whenever DVI inserts a match into a translation, it automatically performs certain conversions:

· The current numbering of embedded codes is used instead of that found in the memory database.

Examples:

	Looking for
	Found source
	Found target
	Target inserted as

	{8}Word{9}
	{001}Word{002}
	{001}Wort{002}
	{8}Wort{9}


· Figures and short acronyms are replaced.

Examples:

	Looking for
	Found source
	Found target
	Target inserted as

	Model CP24, 24 pins
	Model CP9, 9 pins
	Modelo CP9, 9 agujas
	Modelo CP24, 24 agujas


In addition to these automatic conversions, DVI can also perform the following conversions:

· To lower case, upper case or all caps, depending on the capitalization of source text. XE "Case conversions" 
Examples:

	Looking for
	Found source
	Found target
	Target inserted as

	Word
	word
	palabra
	Palabra

	WORD
	word
	palabra
	PALABRA


· Add or remove leading and trailing symbols.

Examples:

	Looking for
	Found source
	Found target
	Target inserted as

	A short phrase.
	A short phrase
	Una frase corta
	Una frase corta.

	Examples:
	Examples
	Ejemplos
	Ejemplos:


· Convert decimal symbols. XE "Decimal conversions" 
Examples:

	Looking for
	Found source
	Found target
	Target inserted as

	RRP 1,100
	RRP 20
	PVP 20
	PVP 1.100


These conversions can be activated by selecting them on the DejaVu options window (see page 55).

· To enable/disable case conversion

· On the DejaVu options window, click on Allow case conversions. XE "Case conversions" 
· To enable/disable leading/trailing symbols control

· On the DejaVu options window, click on Control leading/trailing symbols.

· To enable/disable decimal conversion

· On the DejaVu options window, click on Allow decimal conversions. XE "Decimal conversions" 
Pretranslating XE "Pretranslating" 

 XE "Projects:pretranslating" 
Whenever you begin working on a new project, the first thing you should do is to pretranslate it. This option allows DVI to use the translations that you have previously stored in Déjà Vu’s memory database. Basically, it involves examining the text you are about to translate, and for each sentence in it, scanning the memory database for similar sentences you have translated in the past; Déjà Vu will take the most similar sentence (whether it is an exact
 match or a fuzzy one) and insert it in the corresponding location of the translation.

The simplest form of pretranslation only considers sentences as a whole, and therefore will not find words or isolated expressions inside a sentence. If you want to carry out a more exhaustive search, you can enable the Assemble from portions option (see below).

Note. Although Déjà Vu Interactive will find matches for almost any sentence (provided there is suitable material in the memory database), it will only consider those matches that exhibit a certain minimum degree of similarity. This minimum is controlled by the Fuzziness XE "Fuzziness"  setting in the Options window (page 58). While increasing the value of Fuzziness will make Déjà Vu consider a larger number of matches, it does not increase their quality.

· To pretranslate a project

1. On the Tools menu, click on Pretranslate…
–Or–

Press Ctrl+R.

–Or–

Click on the [image: image116.bmp] button on the tool bar.

2. The Pretranslate options window should appear.
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3. You are offered the following options:

· Pretranslate the current target language or all the languages in the project.

· Pretranslate the current file or all the files in the project.

· Pretranslate only by scanning the memory database for complete sentences (accepting or rejection fuzzy matches), or only by assembling from portions, or using both resources one after the other.

· Prevent Déjà Vu Interactive from pretranslating any sentence for which it has previously found an exact match (green lines) or a fuzzy match (magenta lines)
.

· Pretranslate the whole file(s) or only from the currently selected sentence onwards.

4. Once you have selected the options you want, click on OK.

Since for a large project pretranslating can be a time consuming operation, DVI displays the progress in the status bar.
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Déjà Vu Interactive will now proceed to examine all the sentences in the file(s) and compare them with the sentence pairs stored in the memory database you specified for the project; if it finds similar source language sentences, it will insert the translation corresponding to the most similar
 source sentence, replacing the previous text. Exact matches will be highlighted in green, while fuzzy (approximate) matches will be shown in magenta.
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Depending on the size of the files you are pretranslating, the process may take some time.

Scanning for a sentence XE "Scanning for a sentence" 

 XE "Memory databases" 
As we have already seen in the Pretranslating section (page 85), you can use Pretranslate to search for matches between whole sentences in the text you are translating and sentences in the memory database. Pretranslate is a batch process, and therefore is not useful when you want to search for a match for a single sentence, or when you want to search for a part of a sentence. In these cases, use the Scan sentence function.

· To scan the memory database for a sentence

1. If you want to scan for a part of a sentence, select the text you want to search for in the source sentence box on the lower left part of the DVI Project window. If you want to scan for the whole sentence, do not select any text.

2. On the Tools menu, click on Scan.

–Or–

Press Ctrl+S

–Or–

Click on the [image: image120.bmp] button on the tool bar.

3. If DVI finds any matches in the memory database, the Matches found window will appear:
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Going from top to bottom you will find:

(a) A tool bar with the following icons:

· [image: image122.bmp] – retrieve the target sentence and insert it in the current target cell, to the left of any existing text (you can also press Ctrl+L).

· [image: image123.bmp] – retrieve the target sentence and insert it in the current target cell, replacing its contents (you can also press Ctrl+U).

· [image: image124.bmp] – insert the retrieved sentence to the right of the current target cell text (you can also press Ctrl+R).

· [image: image125.bmp] – copy the retrieved sentence to the Windows clipboard (you can also press Ctrl+B).

· [image: image126.bmp] – exit the window without retrieving anything (you can also press Esc).

· [image: image127.bmp] – launch PowerScan (see below).

(b) Four text boxes containing:

· The source language sentence (or portion) we were searching for (top left).

You cannot edit this text. Any words that do not appear in the matching sentence found will be crossed out. Words (or groups of words) that appear in both sentences, but in a different order, will be displayed in green and/or blue.

· The currently selected match (bottom left).

You cannot edit this text. Any words that do not appear in the sought sentence will be displayed in red. Words (or groups of words) that appear in both sentences, but in a different order, will be displayed in green and/or blue.

· The corresponding translation found in the memory database (bottom right).

You cannot edit this text.

· The translation that DVI proposes for the sought sentence (top right).

You can edit this text; any alterations you make will be included when you use any of the tool bar buttons to insert the sentence into the project.

Note. If you leave the mouse pointer over any of the text boxes for a few seconds, a tool tip describing each of the boxes will appear.

(c) A list containing all the matches found by DVI, with their corresponding translations. You can navigate through the list of matches by using the table’s scrollbar or the following keystrokes:

· Ctrl+PgDn to go to the end of the list.

· Ctrl+PgUp to go to the beginning of the list.

· Ctrl+DownArrow to go to the next match.

· Ctrl+UpArrow to go to the previous match.

Matches are listed in descending order of quality.

Note. If you leave the mouse pointer over the translation of a match on the list (other than the currently selected match), a window will appear over the right column of the list, highlighting the differences between the translation of the currently selected match and the translation pointed to by the mouse.

(d) A status bar displaying the client, subject and creation date for the currently selected match.

4. Select the match you want, and use one of the tool bar buttons to insert it into the project.

You can edit the translation inside the Matches found window, or after you have inserted it into the project.

Scanning with word stems XE "Scanning for a sentence:with word stems" . In order to widen the scope of your searches, you can use wildcards in the text you are looking for. The wildcards you can use to build search patterns are:

· *
a group of characters

· ?
a single character

· [a-m]
one character in the specified range

· ![a-m]
one character outside the specified range

Examples:

· receiv* will find pairs whose source text begins with receive, received, receivable, etc.
· account? will find sources beginning with account and accounts, but not accounting, etc.
· ![a-c]* will find sources that do not begin with any of the first three letters in the alphabet.
Wildcards will work only if you have selected text before launching Scan. Otherwise the search pattern will be treated as regular text.

PowerScan XE "PowerScan" 

 XE "Scanning for a sentence:PowerScan" . The regular Scan feature in DejaVu Interactive saves time by not displaying fuzzy matches when an exact match is found. Also, when searching for single words or small groups of words, it gives perhaps too much importance to sentences that happen to contain two or more occurrences of the text being sought, with the result that sentences containing it just once may not be displayed at all.

Pressing the PowerScan button performs a new scan after removing most restrictions. The result is that single words will be displayed in context even if exact matches are found. The total number of matches that can be shown is not limited in this case.

In some cases, you may want to scan the memory database for a target language word or phrase.

· To scan for a target portion

1. Select the text you want to search for in the target text box.

2. Right-click to bring up the context menu, and click on Scan as source.

You will find that Scan is one of the functions in DVI that you will use most. Once you become accustomed to selecting a few words and pressing Ctrl+S, we are sure you won’t want to go back to your word processor.

Looking up terms in the terminology database XE "Terminology databases" 

 XE "Looking up terms" 
In the same way that you can scan the memory database for a sentence or a part of a sentence, you can search the terminology database for a term.

· To look up a term in the terminology database

1. Select the term you want to look up.

2. Click on the [image: image128.bmp] button on the tool bar.

3. If DVI finds any matches in the terminology database, the Matches found window will appear:

[image: image129.png]& Matches found
EHEE

Searchingfor. vell

Souce

oot

Shguar  Now  Masculne Singular  Noun

04/01/00 201316
Agiicutre & related technalogies





Going from top to bottom you will find:

(a) A tool bar with the following icons:

· [image: image130.bmp] – retrieve the target sentence and insert it in the current target cell, to the left of any existing text (you can also press Ctrl+L).

· [image: image131.bmp] – retrieve the target sentence and insert it in the current target cell, replacing its contents (you can also press Ctrl+U).

· [image: image132.bmp] – insert the retrieved sentence to the right of the current target cell text (you can also press Ctrl+R).

· [image: image133.bmp] – copy the retrieved sentence to the Windows clipboard (you can also press Ctrl+B).

· [image: image134.bmp] – exit the window without retrieving anything (you can also press Esc).

(b) A box displaying the term you were looking for.

(c) A list containing all the matches found by DVI, with their corresponding translations. You can navigate through the list of matches by using the table’s scrollbar or the following keystrokes:

· Ctrl+PgDn to go to the end of the list.

· Ctrl+PgUp to go to the beginning of the list.

· Ctrl+DownArrow to go to the next match.

· Ctrl+UpArrow to go to the previous match.

(d) Two text boxes containing grammatical information for the currently selected source and target terms, respectively.

(e) A status bar that displays the client, subject and creation date for the currently selected match.

4. Select the match you want, and use one of the tool bar buttons to insert it into the project.

The Learn function XE "Learn function" 
When you find a source term of whose translation you are not sure, or one for which you want to verify that you are using the correct translation, you will probably look it up in the terminology database. If this fails, you can perform a memory database scan, which may return a uselessly large set of sentences in which the word in question has been used.

There is a third possibility: let Déjà Vu learn from your previous translations how you have translated that particular word before. This is similar to the way in which small children learn a language — without a dictionary.

Depending on how frequently you have translated that word, Déjà Vu may find a unique target version, or a couple of them, or may become totally confused. A learn search fails if there is not enough material to learn from, or if there is not a clear translation. For example, if you ask it to learn the English words ‘can’, ‘could’, etc. and the target language is Spanish, Déjà Vu will probably be baffled.

· To use the Learn function

1. Select the desired word in the source text (if you are working on the lexicon this is not necessary).

2. Click on the [image: image135.bmp] button on the tool bar.

–Or–

Right-click on the source text box and click on [Learn sentence/selection].

3. DVI will try to ‘learn’ the translation for that word, and will display a list of target words compatible with the material stored in the memory database.
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4. Select an entry from the list by double clicking on it. It will be inserted into the current target cell.

Assembling a translation XE "Assemble from portions" 
When Scanning for a sentence (page 87) doesn’t find a match, you can ask DVI to assemble a translation from smaller pieces, thus squeezing the last drop of information from the lexicon and the databases.

Assemble uses any relevant information that can be found in the project lexicon, terminology database and memory database (in this order). This is why it is important to add manually to the lexicon
 (or directly to the databases) groups of words that are likely to appear repeatedly as a unit.
In all cases, Assemble tries to insert embedded codes in the correct places in the translation.

You can use Assemble for a single sentence or as a batch process when pretranslating.

· To assemble a translation for a single sentence

1. Select the sentence you want to assemble a translation for.

2. On the Tools menu, click on Assemble translation.

–Or–

Press Ctrl+A.

· To assemble translations for a file or the whole project

1. Pretranslate the file or the project with Assemble from portions enabled.

Note. For all that Assemble does, it is extremely fast. If you add any material to the databases or to the project lexicon after the first time you pretranslate a project, you may wish to pretranslate it again with the following options set:

· First scan for whole sentences

· Accept only exact matches when scanning

· Assemble from portions
AutoAssemble XE "AutoAssemble" 
If you want DVI to automatically assemble a translation for the new row when you move to the next sentence by pressing Ctrl+DownArrow (or to the next untranslated sentence by pressing Alt+DownArrow), you can activate AutoAssemble.

· To enable/disable AutoAssemble

· On the DejaVu options windows, click on Enable AutoAssemble.

AutoSearch XE "AutoSearch" 
After you have used Déjà Vu for several projects, you will notice that both the memory database and the terminology database contain a considerable amount of useful information. By the time you reach this stage, you will be quite experienced with the DVI interface, and you may find that having to repeatedly scan the memory database for a sentence or look up a term in the terminology database interferes with your workflow.

By activating a feature called AutoSearch, you can make DVI automatically scan the memory database for the current sentence, and search the memory and terminology databases and the project lexicon for any portions of the sentence.

· To activate AutoSearch

· On the Options menu, click on AutoSearch enabled.

The Sentences found and Portions found windows will appear.
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As soon as you move to a new row in your project, DVI will begin searching the lexicon and the databases. 

The Portions found window XE "Portions found window" 
The Portions found window displays any words or groups of words found in the project lexicon, the terminology database or the memory database. Matches are displayed in the order in which they appear in the current source sentence.
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Going from top to bottom you will find:

· A scrolling table with the list of portions found.

The background color indicates where each match has been found:

· white, in the project lexicon,

· cyan, in the terminology database,

· yellow, in the memory database.

· The complete source and target portions.

· A box indicating where the portion was found (Memory, Terminology or Lexicon).

· Two boxes displaying grammatical information for portions found in the terminology database.

· A status bar displaying client, subject and creation date for the portion.

To minimize the amount of mouse work, you can use the keyboard to navigate through the list of portions, and to paste a selected portion into the target text box.

· To navigate through the Portions found window

· Press Ctrl+P or Ctrl+"­" (numeric keypad) to move to the previous portion.

–Or–

· Press Ctrl+N or Ctrl+"+" (numeric keypad) to move to the next portion.

· To insert the currently selected portion

1. Move the insertion caret to the place where you want to insert the portion.

2. Press Ctrl+T.

–Or–

Double click on the portion.

Notice the numbers in the narrow column between source and target columns. You can also retrieve a target term by holding down the Ctrl key and typing the number of the desired row. You don't even have to press the Ctrl key if you go to Tools/Options/General and clear the following option: Require Ctrl key to navigate PF window.

If you find a portion that is incorrectly translated or does not belong to the location where it was found, you can remove it directly from the list.

· To remove a portion from the lexicon/memory/terminology database

1. Select the portion you want to remove.

2. Right-click on it to bring up the context menu, and click on Remove entry from [MDB/TDB/lexicon].
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Similarly, if you find a portion that is in the memory or terminology database and which you think should be in the project lexicon, you can add it directly from the portions list.

· To add a portion to the lexicon

1. Select the portion you want to add to the lexicon.

2. Right-click on it to bring up the context menu, and click on Add to lexicon.

You can also edit target text on the PF window.

The Sentences found window XE "Sentences found window" 
The Sentences found window displays the list of matching sentences in the memory database, as if you had requested a scan for the current source sentence.
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Going from top to bottom you will find:

· Four text boxes containing:

· The current source sentence (top left).

· The currently selected match (bottom left).

· The corresponding translation found in the memory database (bottom right).

· The translation that DVI proposes for the sought sentence (top right).

· A list containing all the matches found by DVI, with their corresponding translations.

· A status bar, which displays the client, subject and creation date for the currently selected match.

The Sentences found window works just like the Scan results window, except that matches are always inserted at the current insertion point in the target text box.

· To insert a match from the Sentences found window

1. Select the match you want to insert.

2. Make any alterations in the top right text box.

3. Double click on the match.

· To remove a sentence pair from the memory database

1. Select the sentence pair you want to remove.

2. Right-click on it to bring up the context menu, and click on Remove entry from MDB.

Verification functions XE "Terminology checks" 

 XE "Checking terminology" 
Checking for consistency

DVI can check a translation is consistent with the material available in the project lexicon and the terminology database.

This feature, Check terminology, can be useful, for example, for project managers who need to check whether or not a translation conforms with the glossary prepared in advance for a given project.

Check terminology searches the project lexicon and the terminology database for words and groups of words in source text and makes sure that the correct translations have been used in target text. The memory database will also be used if the Display portions from memory database option has been activated (page 55).

Check terminology can optionally check for mismatches in numerals between source and target. This is controlled by the Check also numerals option (page 56). Numerals are compared using language-dependent conversion rules if the Allow decimal conversions option has been activated (page 55).  XE "Checking numerals" 

 XE "Decimal conversions" 
· To check terminology usage for the current row

· On the Tools menu, click on Check terminology (single row), 

–Or–

Press Shift+F7

Any mismatches, either in terminology usage or in numerals, are highlighted in red.

If no mismatches are found, DVI will move to the next row.

· To check terminology usage for the current row and the following ones

· On the Tools menu, click on Check terminology, 

–Or–

Press Ctrl+Shift+F7

DVI will stop at the first row were a problem is detected. You can also interrupt the process by pressing the Esc key.

Any mismatches, either in terminology usage or in numerals, are highlighted in red.

The project lexicon XE "Lexicon" 
We have already stressed the importance of using the lexicon, but we haven’t explained what the lexicon is, or how to use it. The project’s lexicon is the list of all the source language words or phrases present in the project.

Quite often, clients will request that you provide them with a glossary for a project you have translated for them; this will help them keep a record of the terminology used, ensuring that the same terminology is used in future projects. With DVI, creating a glossary for your client is as simple as exporting the lexicon to a text file.

If a client sends you a glossary with the terminology he wants you to use for the project, you can import the glossary into the terminology database (or the memory database if the glossary contains expressions or phrases as well as terms); you can then create the project lexicon and automatically translate it using the information in the databases.

Once you have built and translated the lexicon, it will prove invaluable in improving the results of Assemble. Therefore, we recommend that you include commonly used terms and expressions in the lexicon.

Building the lexicon

· To create the lexicon

1. On the File menu, open the Lexicon submenu and click on Build.

2. The following window will appear:
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3. You are offered the following options:

· Specify the maximum number of words for a lexicon entry.

· Specify no limit on the maximum number of words for a lexicon entry.

Note. When adding entries to the lexicon, the sentence segments that DVI considers must be bounded by a text delimiter such as a comma or a semicolon; you will not find lexicon entries with a comma in the middle.

· Specify whether DVI should try to translate the lexicon entries as it creates them, using the terminology and memory databases for the project

4. Select the options you want, and click on OK.

Depending on the size of the project, building the lexicon may take some time, since DVI has to process each sentence in the project a number of times. While DVI is working on creating the lexicon, you will see a progress indicator in the status bar.

Once DVI has finished building the lexicon, you can view it by selecting Lexicon for this project from the file selector.
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The first column on the table, with the heading Nw Freq, shows the number of words in the lexicon entry, and the frequency, i.e., the number of times it appears in the project.

Sorting the lexicon

As with normal files in a project, you can change the order in which the lexicon entries appear.

· To change the lexicon sorting

1. Click on the [image: image143.bmp] button on the toolbar.

The Sort lexicon window appears.
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You can sort alphabetically, by number of words, by frequency, or by any combination of the three.

2. Select how you want to sort by selecting an option from the Sort first by dropdown list.

You can also choose to sort in ascending or descending order.

3. When two or more entries coincide on the first characteristic by which you are sorting the lexicon, you can specify to sort them on any of the remaining two, and so forth.

4. Click on OK.

For best results, we recommend that you sort by descending frequency, then by ascending number of words, and finally by ascending source text. This way, you will easily see those terms or phrases that appear most commonly in the project. Evidently, there will be a large number of words which are not worth translating, e.g. “and,” “this,” “the,” etc. (for a project in English). Simply skip these, and concentrate on those which are meaningful to the project.

Removing entries from the lexicon

You will probably want to delete the lexicon entries that only appear once or twice in the project, or those that contain a very large number of words.

· To remove rows from the lexicon

1. On the File menu, open the Lexicon submenu and click on Remove rows…
The Remove lexicon rows window will appear.
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2. You are offered the following options:

· Remove the entire lexicon.

· Remove those lexicon entries for which you have not entered a translation.

This is useful when you have finished translating the lexicon and want to export it to send to your client as a glossary; you can remove the entries you have not translated because you considered they were not useful.

· Remove lexicon entries based on the number of words they contain and/or their frequency. You can also specify whether to remove those entries that satisfy these conditions and have not been translated, thereby preserving any special entries you decided to keep.

For example, to remove all the entries with frequency one and two or more words (which would clearly serve no purpose and use a large amount of disk space
), type 1 in the words in source box and select or less in the corresponding dropdown list, and type 2 in the occurrences box and select or more in the corresponding dropdown list.

3. Select the options you want and click on OK.

Adding entries to the lexicon

If you remove entries from the lexicon and then discover that you are missing a term that should be included, you can always add a new entry to the lexicon.

· To manually add an entry to the lexicon

1. Make sure you have selected Lexicon for this project in the file selector.
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2. Press Ctrl+PgDn to go to the end of the lexicon.

3. Click on the last line in the table (the one marked with an asterisk).

4. Type your entry in the source and target text boxes.

[image: image147.png]



The new entry will be added with frequency 0.

You can also add a sentence pair (or a selection) from the current project file to the lexicon.

· To add a sentence pair to the lexicon

1. If you want to add a selection, select the corresponding portions in the source and target text boxes.
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2. On the Tools menu, click on Add [pair/selections] to lexicon.

–Or–

Press Ctrl+F9

–Or–

Right-click on the target text box, and click on Add [pair/selections] to lexicon.

Because of the way in which Déjà Vu takes advantage of the lexicon, it is worthwhile to expand it by manually adding entries for phrases or other groups of words in the project.

For example, if the lexicon contains entries for “ink” and “jet”, you may wish to add one for “ink jet”. The more entries you add, and later send to the database, the more efficient Assemble will be.

Resolving the lexicon

Once the lexicon has been built and you have added and removed those entries you considered necessary, you should translate it. There are three procedures that help you in translating the lexicon, available from the Lexicon submenu on the File menu:

· Resolve with memory database.

This works like a pretranslation; i.e., it finds both exact and fuzzy matches in the memory database.

· Resolve with terminology database.

Finds matches in the terminology database.

· Resolve with ‘learn’ function

Executes a learn
 operation for each entry in the lexicon.

(All the above work is done with the currently selected target language. If there is more than one language in the project, you can choose which one to display by selecting a language from the language selector.)

We recommend that you check the translations generated by the ‘resolve’ procedures.

Of course, you can translate an entry manually by typing the translation into the target text box.

Sending the lexicon to a database

After expanding, translating and correcting the lexicon, you should send it to the terminology database or the memory database
. This is essential if you want Déjà Vu to use this information for other projects.
· To send the lexicon to the memory/terminology database

1. On the File menu, open the Lexicon submenu and click on Send to [memory/terminology] database.

2. The Send what? window will appear, offering you the following options:
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3. Select whether you want to send the currently selected language or all the target languages for the project.

4. Select whether you want to send all the sentences in the currently selected file or the sentences in all the files in the project.

5. Select whether you want to send ‘green’ lines. Green lines represent exact matches generated by one of the ‘resolve’ functions.

6. Select whether you want to send ‘magenta’ lines. Magenta lines represent fuzzy matches generated by one of the ‘resolve’ functions. Magenta lines should not be sent unless you are sure that they are correct.

7. If you have chosen to send the lexicon to the memory database, select whether you want to delete all sentences previously sent from this project. If you have previously sent any entries from this lexicon, and you have since corrected any errors in their translation, you should select this option. This is especially useful if you have previously sent ‘magenta’ entries, and have corrected them.

8. Click on OK.

Exporting the lexicon

Once you have processed the lexicon, you may want to export it to send it to your client. DVI will create a text file with the lexicon entries from the source language and the currently selected target language. The text file is a standard tab-delimited text file; i.e., the structure of each row is:

NW<Tab>Freq<Tab>Source entry<Tab>Target entry

A file with this structure can be opened or imported into almost any word processor. For example, with Microsoft Word you could:

1. Open the file.

2. Select all the text.

3. Use Word’s Table/Convert text to table menu option.

4. Select each column in turn and assign the desired font attributes. The file is now a Word document that you can print or process in any way you desire.

· To export the lexicon

1. On the File menu, click on Export two columns to text file…

2. The Export to text file window appears.
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3. Select Lexicon (current sorting).

4. You have the following choices:

· Only rows with empty targets.

Export only rows not yet translated and for which a ‘resolve’ operation has not found any matches.

· Only rows with non-empty targets.

Export only rows that have been translated.

· All rows.

Export rows regardless of whether target is empty or not.

You also have the following options:

· Suppress duplicate rows.

If there are any duplicate rows, only one copy will be exported.

· Suppress locked rows.

Do not export rows that have been marked as locked.

· Suppress embedded codes.

Eliminate any embedded codes that may be present in the entries.

5. Select the options you want, and click on OK.

6. On the file selector that appears, select a file to export to, or type the name of a new file (it will be created).

7. Click on OK.

Saving your translations

As we explained in the introduction, Déjà Vu is a translation memory tool, i.e., a program that allows you to take advantage of previous translations to save time when you translate. DVI automatically saves your project every time you translate a sentence, so you do not need to worry about saving your project. 

Therefore, it is crucial that you save your translations from source to target languages in order to be able to use what you have already translated.

Sending information to the memory database

There are three ways to manually send information to the memory database from Déjà Vu Interactive:

· Send only a sentence pair from the translated project.

· Send only a portion of the sentence pair.

· Send the whole translated project to the memory database.

· To send a sentence pair to the memory database

1. Select the sentence you want to send to the memory database.

2. On the Tools menu, click on Send pair to memory database.

–Or–

Press Ctrl+F12

–Or–

Click on the [image: image151.bmp] button on the tool bar.

–Or–

Right-click on the source or target text box and click on Send pair to memory database XE "Send to memory database:pairs" .

· To send only a portion of the sentence pair to the memory database

1. Select the portion of the source sentence and the portion of the target sentence that you want to send to the memory database.

2. On the Tools menu, click on Send selections to memory database.  XE "Send to memory database:selections" 
–Or–

Press Ctrl+F12

–Or–

Click on the [image: image152.bmp] button on the tool bar.

–Or–

Right-click on the source or target text box and click on Send selections to memory database.

· To send the whole project to the memory database XE "Send to memory database:whole project" 
1. On the Tools menu, click on Send translated project to memory database.

–Or–

Press Ctrl+F10.

–Or–

Click on the [image: image153.bmp] button on the tool bar.

2. A window will appear, offering you the following options:
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· Select whether you want to send the currently selected language or all the target languages for the project.

· Select whether you want to send all the sentences in the currently selected file or the sentences in all the files in the project.

· Select whether you want to send ‘magenta’ lines. Magenta lines represent fuzzy matches generated by a Pretranslation. Magenta lines should not be sent unless you are sure that they are correct.

· Select whether you want to delete all sentences previously sent from this project. If you have previously sent any sentences from this project, and you have since corrected any errors in the translation, you should select this option. This is especially useful if you have previously sent ‘magenta’ lines, and have corrected them.

· If you want to create a text file containing all the sentence pairs which Déjà Vu Interactive will add to the memory database, enter a file name (including the path), or click on Browse to open a file selector and locate the file you want to write the pairs to.

3. Click on OK.

AutoSend XE "AutoSend" 
If you want to automatically send sentences to the memory database when you finish translating them, you can activate AutoSend.

· To enabled/disable AutoSend

· On the Options menu, click on AutoSend to memory database.

Note. A sentence will only be sent to the memory database automatically if you move to the next sentence by pressing Ctrl+DownArrow (or to the next untranslated sentence by pressing Alt+DownArrow).

Sending information to the terminology database XE "Send to terminology database:pairs" 
There are three ways to manually send information to the memory database from Déjà Vu Interactive:

· Send a whole sentence pair (or pair of lexicon entries) from the translated project.

Note. This procedure is only encouraged for lexicon entries. Complete sentences should be sent to the memory database.

· Send only a portion of the sentence pair.

· To send a pair of terms to the terminology database

1. Select the portion of the source sentence and the portion of the target sentence, which you want to send to the terminology database.

2. On the Tools menu, click on Send selections to terminology database.

–Or–

Press Ctrl+F11

–Or–

Click on the [image: image155.bmp] button on the tool bar.

–Or–

Right-click on the source or target text box and click on Send selections to terminology database.  XE "Send to terminology database:selections" 
3. The Details of term window appears.
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4. If pertinent, use the Client and Subject dropdown lists to set client and subject information for the term.

5. You can also use the Gender, Number and Part of speech dropdown lists to specify grammatical information for the source and target terms.

6. If you want, enter a definition or a comment in the Definition/comments text boxes.

7. Click on Add.

Editing functions

DVI is an environment designed to increase your productivity as a translator; this involves not only reusing existing translations, but also making translating new material easy. Consequently, you will find that DVI includes a host of powerful editing features, akin to those found in your word processor.

Spell checking XE "Spell checking" 
Spell checking is available for the following languages: English (USA and U.K), Danish, Dutch, Finnish, French, German, Italian, Norwegian (Bökmal), Spanish, Swedish and Portuguese (Brazil and Portugal).

· To activate spell checking

· On the Tools menu, click on Check spelling…
–Or–

· Press F7.

–Or–

· Click on the [image: image157.bmp] button on the tool bar.

The Check Spelling window

Whenever DVI finds a word it does not recognize, it will display the Check Spelling window:
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Going from top to bottom, you will find:

· The Not in Dictionary box.

This box displays the misspelled word that was detected. The word is considered misspelled because it could not be located in any of the open dictionaries, or was located in an exclude-type dictionary. You can change the word by selecting the Change button, or skip it by selecting the Ignore button.

· The Lock position checkbox.

Checking this option locks the position of the Check Spelling window in place. Normally the Check Spelling window attempts to position itself to avoid the window containing the text being checked. When the Lock checkbox is checked, the Check Spelling window will always appear at the last place where you positioned it.

· The Change to box.

This box contains a word that will replace a misspelled word when you select the Change or Change All buttons. You can enter a word in the Change To box by typing, or you can select one of the suggested replacements from the Suggestions list.

· The Suggestions list.

This list shows the suggested replacements for the word reported as misspelled. If you have enabled the Always Suggest option, this list will be filled in automatically when a misspelled word is reported. Otherwise, the list is filled in when you select the Suggest button. A word selected in this list will be automatically copied to the Change To box, where it can be substituted for the misspelled word by pressing the Change button.

· The Ignore button.

Clicking on this button will skip this occurrence of the misspelled word. If the same misspelled word appears later, it will be reported.

· The Ignore All button.

Clicking on this button will skip this and all further occurrences of the misspelled word. You might use this button if the word reported as a misspelling is actually spelled correctly. If the word is one you use frequently, you may wish to ignore it permanently by clicking on the Add button.

· The Change button.

Clicking on this button will replace the reported word with the word in the Change To box. Only this occurrence of the reported word is replaced. If you want this and all following occurrences of the word replaced, select the Change All button.

· The Change All button.

Clicking on this button will replace this and all further occurrences of the reported word with the word in the Change To box. If you only want to replace this occurrence of the word, use the Change button. If the reported word is one you frequently misspell, you might consider adding it to a change-type or suggest-type dictionary via the Dictionaries window. You can display the Dictionaries window by selecting the Dictionaries button.

· The Add button.

Clicking on this button will add the reported word to the dictionary selected in the Add Words To list. Use the Add button if a correctly spelled word you use often is reported as a misspelling (e.g., the name of a product). If the word is not used frequently, you may want to use the Ignore or Ignore All buttons instead.

· The Suggest button.

Clicking on this button will display a set of suggested replacements for misspelled words in the Suggestions list. This button is enabled only if the Always Suggest option is disabled. Each time you select the Suggest button, a more intensive search for replacements is conducted. Once all possible suggestions are located, the Suggest button is disabled.

· The Add Words To list.

Use this dropdown to select the user dictionary to which words will be added to when you use the Add button. The Add Words To list shows all ignore-type user dictionaries currently open. You can open or close other dictionaries via the Dictionaries window, which is displayed by clicking on the Dictionaries button.

· The Dictionaries button.

Clicking on this button will display the Dictionaries window. You can use the Dictionaries window to open or close user dictionaries, and to edit the contents of user dictionaries.

· The Options button.

Clicking on this button will display the Options window. You can use the Options window to set the spell checker options.

· The Cancel button.

Clicking on this button will stop the current spell checking operation.

The spell checking Options window

If you click on the Options button in the Check Spelling window, DVI will display the spell checking Options window:
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You can use the Options window to specify various spell checker options. These options affect the way the spell checker operates.

Going from top to bottom, you will find the following options:

Ignore capitalized words.

When this option is enabled, any words beginning with a capital letter are ignored (i.e., are skipped over without being checked). You might enable this option if the text being checked contains many proper names.

Ignore all-caps words.

When this option is enabled, any words containing all capital letters are ignored (i.e., are skipped without being checked). You might enable this option if the text being checked contains many acronyms.

Ignore words with numbers.

When this option is enabled, any words containing embedded digits are ignored (i.e., are skipped without being checked). Examples of such words include “Win95” and “Q4.” You might enable this option if the text being checked contains many code words or other symbols containing digits.

Ignore words with mixed case.

When this option is enabled, any words containing an unusual mixture of upper- and lower-case letters are ignored (i.e., are skipped without being checked). Examples of such words include “MicroHouse” and “CapsLock.” You might enable this option if the text being checked contains many variable names or other symbols which use case changes to distinguish words.

Report doubled words.

When this option is enabled, any word appearing twice in a row is reported in the Check Spelling window.

Case sensitive.

When this option is enabled, a distinction is made between capitalized and non-capitalized words. For example, “canada” is considered different from “Canada”, so “canada” would be reported as a misspelling. When the option is disabled, “canada” and “Canada” are considered identical.

Always suggest.

When this option is enabled, a list of suggested replacements is automatically displayed when a misspelled word is reported. If this option is disabled, a list of suggestions can be obtained by selecting the Suggest button in the Check Spelling window.

Phonetic suggestions.

When enabled, suggestions are made based on phonetic similarity as well as typographical similarity. This option tends to improve suggestions for badly misspelled words. Enabling this option will increase the time required to locate suggestions.

Suggest split words.

When this option is enabled, two separate words will be suggested as a replacement for a misspelling containing two joined words. For example, “is the” would be suggested as a replacement for “isthe.”

Match case in replacements.

When this option is enabled, automatic replacements and suggested replacements will use the same letter case as the original word. If the original word was capitalized, for example, then the replacement or suggested word will also be capitalized. When disabled, the replacement or suggested word will use the case in which it is listed in the dictionary. If you turn this option off, you can use an auto-change dictionary to expand acronyms and abbreviations.

The Dictionaries window

If you click on the Dictionaries button in the Check Spelling window, DVI will display the Dictionaries window:
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The Dictionaries window allows you to open and close user dictionaries, and to edit the contents of an open user dictionary. The contents of dictionaries are saved in disk files. You can open some or all of your user dictionary files at any time. Only open dictionaries are checked during a spell checking operation.

Going from top to bottom, you will find:

· The Words list.

This list displays all the words in the currently selected user dictionary. If the dictionary type is auto change or conditionally change, then the list contains words and their replacements, separated by colons.

· The Add Word button.

Clicking on this button will add the word entered in the edit area of the Words list to the currently selected dictionary. Note that if the dictionary type is auto change or conditionally change, you must enter a word and a replacement, separated by a colon (e.g., “teh:the”). Also note that the Add Word button is enabled only when a new word is typed in the edit area of the Words list. The words you add may contain virtually any character, but only words that contain embedded periods should have trailing periods (e.g., U.S.A. is fine, but USA. is not).

· The Delete Word button.

Clicking on this button will remove the currently selected word (in the Words list) from the currently selected dictionary.

· The Import button.

Clicking on this button will add the words contained within a text file to the currently selected dictionary. When you click on the Import button, a window appears which you can use to select the text file to be imported. Each word in the selected file is loaded into the dictionary. If the dictionary type is auto change or conditionally change, words in the file must be in the form word:replacement (e.g., “teh:the”).

· The Export button.

Clicking on this button will save the contents of the currently selected dictionary to a text file. When you click on the Export button, a window appears which you can use to select the name of the text file to which words in the dictionary will be exported. The words are written to the file one per line. If the dictionary type is auto change or conditionally change, words and their replacements are separated by a colon.

· The Files list.

Use this dropdown to select one of the currently open dictionary files. When you select a dictionary from the list, its contents are displayed in the Words list.

· The Language field.

This field displays the language (e.g., English or French) of the words in the currently selected dictionary.

· The Type field.

This field displays the type or purpose of the currently selected user dictionary. The dictionary type indicates what will happen if a word is located in the dictionary during a spelling check.

· The Add File button.

Clicking on this button will open a user dictionary file. When you click on the Add File button, a window appears which you can use to select the dictionary file to open. The set of open dictionary files is remembered, so once you add a dictionary file you don’t need to add it again. If you need to create a new user dictionary, use the New button.

· The New button.

Clicking on this button will create a new user dictionary file. When you click on the New button, a window appears which you can use to specify attributes of the new dictionary. See the New Dictionary window for details.

· Remove File button.

Clicking on this button will close the currently selected dictionary file. Closed dictionaries are not checked during a spell check. Although the file is closed, it is not deleted. Closed dictionary files can be later reopened using the Add File button.

The New Dictionary window

If you click on the New… button in the Dictionaries window, DVI will display the following window:
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You can use the New Dictionary window to specify the attributes of a new user dictionary.

Going from top to bottom, you will find the following options:

· The File Name box.

This box displays the name of the disk file used to hold the new dictionary’s contents. You can enter a name here or use the Browse button to display a window showing the names of other dictionary files. If you click on the Browse button, a file selector will appear, showing the names of other user dictionary files. You can use the window to view the names of existing dictionary files, and to enter the name of the new dictionary file.

· The Type list.

Specify the type of dictionary you want to create, by selecting an option from this list. The type defines what happens when a word is located in the dictionary during a spelling check. The four options are:

· Auto Change.

Words found in an Auto Change dictionary are automatically replaced with other words. Typically, Auto Change dictionaries hold frequently misspelled words and their correct replacements. For example, an Auto Change dictionary might contain the misspelled word “recieve” and its replacement “receive.” Each entry in an Auto Change dictionary contains a word and its replacement, separated by a colon (e.g., “recieve:receive”).

· Conditional Change.

Words found in a Conditional Change dictionary are presented to you as candidates for replacement, and are replaced with other words if you request. Typically, Conditional Change dictionaries hold potentially misspelled words and their usual replacements. Each entry in a Conditional Change dictionary contains a word and its replacement, separated by a colon (e.g., “recieve:receive”).

· Exclude.

Words found in an Exclude dictionary are always considered misspelled, even if they are defined in other dictionaries. Typically, Exclude dictionaries hold words you may use but don’t want to appear in your writing. You might also use an Exclude dictionary to hold words you type by accident — for example, you might enter “newt” in an Exclude dictionary if you occasionally type “newt” when you mean to type “neat.”

· Ignore.

Words found in an Ignore dictionary are considered correctly spelled. Typically, Ignore dictionaries hold words you use but which don’t appear in the other dictionaries. For example, you may add your family name or street name to an Ignore dictionary.

· The Language list.

Use this list to select the language (e.g., French, English) of the new user dictionary. If the language you want to use is not listed, select Other.

Character map XE "Character map" 
You can press Ctrl+K to display Windows character map — convenient when you have to insert special or accented characters for which you don’t remember the ANSI code.

If when you press Ctrl+K the Windows character map does not appear, it is probably because it is not installed.

· To install the Windows character map

1. Open the Windows Start menu.

2. Open the Settings submenu, and select Control Panel.

3. Double click on Add/Remove Programs.

4. Select the Windows Setup tab.

5. Click on Accessories.

6. Click on Details.

7. Make sure Character map is selected.

8. Click on OK.

Note. Windows will probably ask you for your Windows installation CD-ROM.

Search and replace XE "Search and replace" 
If you discover you have incorrectly translated a specific term, you can use ‘search and replace’ to locate and replace any mistranslations.

· To use search and replace

1. On the Edit menu, click on Search/replace.

–Or–

Press Ctrl+H.

–Or–

Click on the [image: image162.bmp] button on the tool bar.

2. The Replace window will appear.
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3. In the Find What box, enter the text you want to search for.

You can use the dropdown list to select any text you searched for recently.

4. If you want to replace the found text, enter the text in the Replace With box.

You can use the dropdown list to select any text you replaced with recently.

5. Select whether you want to search in the source or target column.

6. You have the following options:

· Start from beginning of project.

If this option is selected, the search and replacement is carried out throughout the whole project. Otherwise, it is only done from the current sentence onwards.

· Find whole word only.

If this option is selected, DVI will only find complete words that match the text in the Find What box. Otherwise, words which begin with the search text will also be found.

· Match case.

If this option is selected, DVI will only find text that matches the case of the search text.

7. You can click on:

· Find Next.

This will find the next (or first) occurrence of the search text.

· Replace.

This will replace the next occurrence of the search text with the replace text.

· Replace All.

This will replace all occurrences of the search text with the replace text.

8. To close the window, click on Cancel.

AutoText XE "AutoText" 
AutoText saves you typing effort by expanding abbreviations to arbitrarily long text. For example, you can create an AutoText entry, “DVI”, that expands to “Déjà Vu Interactive.” This can prove extremely useful for projects where you often have to type in, for example, a product or company name.

AutoText entries are language specific. The set of AutoText entries that is active at a given time is the one corresponding to the target language currently selected.

There are two kinds of AutoText entries: project-specific and global. Project-specific entries take precedence over global ones.

· To expand an AutoText entry

1. Type the entry you want to expand.

2. Press F8.

The entry will be expanded automatically as soon as you type it if you have activated the AutoText as you type option. XE "AutoText:as you type" 
Copying from source to target XE "Copying from source to target" 
There may be special situations in which you want to work throughout the project on a copy of the source text rather than on empty target cells.

Populating XE "Populating" 
You can ask DVI to copy all the source material to the current target column. This is called populating the column.

· To populate the current target column

· On the Tools menu, click on Populate current target.

· To populate all the target columns

· On the Tools menu, click on Populate all targets.

In both cases, you will be asked for confirmation.

Copying single sentences

Populate is a rather ‘dangerous’ function, in that it will copy the source column to the target column for all files. You might prefer to manually copy the source text for a single sentence.

· To copy the current source to the current target

1. Select the row you want.

2. On the Tools menu, click on Copy source to target.

–Or–

Press F5.

–Or–

Click on the [image: image164.bmp] button on the tool bar.

–Or–

Right-click on the row (or the target text box) and click on Copy source to target.

You can also copy several rows by selecting them on the table and following the same procedure.

· To copy the source text for all visible rows

· On the Tools menu, click on Copy source to target (whole page).

–Or–

· Press Shift+F5.

–Or–

· Hold down the Shift key and click on the [image: image165.bmp] button on the tool bar.

Note. If you hold down the Ctrl key while you click on the [image: image166.bmp] button, source text will overwrite target text, rather than being inserted to its left. If you hold down the Alt key, only embedded codes will be copied.

Propagating a translation XE "Propagating" 
Once you have translated a sentence, you can propagate the translation either throughout the project or only in the current source file.

· To propagate a translation in the current file

1. Select the translation you want to propagate.

2. On the Tools menu, click on Propagate in current file.

–Or–

Press F11.

–Or–

Click on the [image: image167.bmp] button on the tool bar.

· To propagate a translation to all the files

1. Select the translation you want to propagate.

2. On the Tools menu, click on Propagate to all files.

–Or–

Press F12.

–Or–

Click on the [image: image168.bmp] button on the tool bar.

The translation being propagated is inserted into any target cells for which the source text is equal, or almost equal, to the original source. For example, consider this situation:

	{1}Word{2}
	{1}Palabra{2}

	…
	

	{41}Word{42}
	

	…
	

	{129}Word{130}
	


If you select the first row and propagate it, you’ll get:

	{1}Word{2}
	{1}Palabra{2}

	…
	

	{41}Word{42}
	{41}Palabra{42}

	…
	

	{129}Word{130}
	{129}Palabra {130}


Notice that, when searching for cells to propagate to, DVI will ignore digits and embedded codes. Destination cells are written nevertheless with the correct digits and codes inserted in place.

Normally, Propagate inserts text only into empty target cells, without overwriting anything. If you wish to force the propagation also to non-empty cells, hold down the Shift key before clicking on the propagate buttons.

After propagating to equal source rows, DVI will look for rows where the source text is only similar to the one being propagated. If any such rows are found, DVI will offer them in a separate window:
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You can propagate to these cells and edit the translation in this window. Click on the desired table row. Then click on [image: image170.bmp] to copy the translation to the Found target box. Finally, enter your modifications.

AutoPropagate XE "AutoPropagate" 
If you want DVI to automatically propagate sentences when you finish translating them, you can activate AutoPropagate.

· To enable/disable AutoPropagate

· On the DejaVu options windows, click on AutoAssemble.

Note. A sentence will only be autopropagated if you move to the next sentence by pressing Ctrl+DownArrow (or to the next untranslated sentence by pressing Alt+DownArrow).

Change case XE "Change case" 
You can press Shift+F3, or click on Change case on the Edit menu, to change the case of the text in the target box. Each time you press this key combination, DVI will cycle through the following states:

· First letter uppercase, the rest lowercase.

· All lowercase.

· All uppercase.

This function affects the text that is selected in the target box or, if no text is selected, the whole target sentence.

If you want to use Shift+F3 for the source box, make sure no text is selected in the target box; select the desired text in the source box (either the complete sentence or a portion thereof); finally press Shift+F3.

Controlling rows with duplicate source XE "Duplicate source, rows with" 
You can use the right-most button on the toolbar to find and display sets of rows with the same source text.

· To find rows with duplicate source

1. Click the arrow on the right-most button on the toolbar and select the first option.
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Select the desired options on the ‘Find duplicates’ window.
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DVI will highlight rows with duplicate source by painting magenta the corresponding source cells on the table.

Using the same button and menu you can revert to displaying all rows. You can also ask DVI to forget about duplicates rows.

Project management XE "Projects:management" 
If you work as part of a group of translators, or you work as project manager in a translation agency, you know how hard it is to coordinate multilingual projects with several translators. DVI provides a set of powerful project management features to help you with such tasks:

· Satellite projects.

Small, single language projects without the formatting, image and layout information that make DTP format projects extremely large. You can distribute these easily among translators, and reimport them to generate the complete multilingual project.

· Extracting subsets from the databases.

If you send a satellite to a translator, you may wish to include subsets of the memory and terminology databases with the material related to the current project.

· Project security.

You can define a project manager and any number of translators for each of the languages in the project. Translators can have priority levels, which prevent translators with a lower level from overwriting translations done by a supervisor. This allows multiple translators to work on the same language in a project.

· Row locking.

If a project contains some sentences that should not be translated, the project administrator can lock those rows to prevent them from being translated.

· Controlling which rows are stored in the memory database.

Satellite projects XE "Projects:satellites" 

 XE "Satellite projects" 
Once a DVI project has been created and the external files have been imported, it is possible to generate satellite work files, one per target language.

A satellite contains only two columns (as opposed to a full project file, which typically consists of the source column plus a number of target columns). A satellite includes all the information needed by the translator, but none of the formatting and image code that usually makes a DTP project immense in terms of hard disk requirements. A satellite is, therefore, what should be sent by a translation company to individual translators who work at home.

Once the translation of a satellite is finished, it can be imported into its parent full project file.

· To create a satellite project

1. On the Files menu, click on Export satellite.

The Export satellite options window will appear.
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You can choose whether to create a satellite for the current target language or for all the target languages in the project.

2. Choose the option you want.

3. Click on OK.

For each satellite DVI creates, it will display a file selector for you to specify the name and location of the file.

Warning. Once a satellite is exported, neither the project administrator nor the translator working on a satellite project should join or split sentences, since this will prevent DVI from correctly importing the satellite project into the final project.

· To import a satellite project

1. On the Files menu, click on Import satellite.

2. In the file selector that appears, select the satellite project you want to import.

3. DVI will merge the satellite project with the complete project automatically.

Extracting subsets from the databases  XE "Projects:satellites" 

 XE "Satellite projects" 
For each target language in the project, you can create a subset of the memory database or the terminology database. You may wish to send these smaller, project-specific databases to translators, together with satellites.

· To create a subset of a memory or terminology database

1. Use the language selector to select the desired target language.

2. On the Files menu, click on Extract database for this project and select either Subset of memory database or Subset of terminology database.

You will be asked to specify the destination database and to decide whether you want to create a new database, to replace the selected database or to append to it the exported material.

Project security XE "Projects:security" 
DVI allows you to define translators (complete with user levels and passwords) for a project.

· To enable project security

1. Open the Project configuration window.

2. Select Security enabled.
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3. DVI will display a window, asking for a user name and password of the project owner.
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By default, DVI offers the name of the user currently logged in Windows. You can change this to your user name.

4. Enter your user name and password.
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5. Click on OK.

Since there are no translators defined for the project, DVI will inform you of this.
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6. Click on OK.

DVI will ask you whether you want to be the owner of the project.
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7. Click on Yes.
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DVI will ask you for your full name. Enter it and click on OK.

8. Notice that a new tab, Translators, has been added to the Project configuration window.

[image: image180.png]Pt paanetes | Lngusges | Tanstors |

Project tile




Once project security is enabled, you can add translators to the project and assign each translator a level.

Note. Only the project owner can add or remove translators from the project.

· To add a translator to the project

1. Open the Project configuration window.

2. Select the Translators tab.
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3. Double click on the last row of the Available translators table, and enter the nickname and full name of the translator.

4. On the Target languages table, select the language you want the translator to work on.

5. Drag the translator from the Available translators table to the Translators for [the language you selected] table.
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6. Enter a number representing the level of the translator.

Clearly, if you have a large number of translators involved in a project, manually entering the details for each translator will be cumbersome. Fortunately, you can import the list of translators from other projects.

· To import a list of translators from a project

1. Open the Project configuration window.

2. Select the Translators tab.

3. Click on Import list of users.

4. In the file selector that appears, select the project that contains the list of translators you want to import.

5. Click on Open.

If project security is active, a translator will not be able to type anything until she logs in with a valid name and password. Whenever a user with a higher level enters a translation, a user with a lower level will not be allowed to modify it; the project owner has the privilege of overwriting all of the other translators’ work.

· To login

· On the Users menu, click on Login.

When logging in for the first time, a translator (other than the project owner) must specify a password.

· To logout

· On the Users menu, click on Logout.

· To change the user password

1. On the Users menu, click on Change password.

2. Enter the current password.

3. Enter the new password.

4. Confirm the new password.

5. Click on OK.

Row locking XE "Row locking" 

 XE "Locking rows" 
It is possible to lock rows in the project so that you cannot accidentally change their target text.

· To lock a group of rows

1. Select the row(s) you want to lock.

2. Right-click on the scrolling table and click on Lock selected rows.

· To unlock a group of rows

1. Select the row(s) you want to unlock.

2. Right-click on the scrolling table and click on Unlock selected rows.

Target text in locked rows is protected against typing into the target box. Indirect modifications such as those caused by ‘copy to target’, populate, propagate, pretranslate and scan operations are also prevented.

This feature should be used by project coordinators who need to lock target text before letting the translators begin to work with the project.

Controlling which rows are stored in the memory database

· To prevent a row from being sent to the memory database

1. Select the desired row.

2. Right-click on the sentence table and click on Prevent row from being sent to MDB.

–Or–

Press Ctrl+Y.

A ‘wrong direction’ symbol will appear between the two columns.
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· To allow a row to be sent to the memory database

1. Select the desired row.

2. Right-click on the sentence table and click on Allow row to be sent to MDB.

–Or–

Press Ctrl+Y.

The ‘wrong direction’ symbol will disappear.

Word count XE "Word count" 
When you have finished a project and you need to prepare an invoice for your client, or when you are trying to assess the progress of a translation, you can ask DVI to count the number of words and characters in a project.

· To count the words and characters in the project

1. On the Tools menu, click on Count words and characters.

The Word and character count window should appear.
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2. You can choose to display:

· All rows.

Display all the rows for the currently selected target language.

Or any combination of the following:

· Finished (gray) rows.

Display those rows that the translator has marked as finished (using Ctrl+DownArrow or Alt+DownArrow).

· Empty target rows.

Display those rows that have not been translated.

· Exact match (green) rows.

Display rows that have been inserted as exact matches by one of DVI’s translation functions.

· Fuzzy match (magenta) rows.

Display rows that have been inserted as fuzzy matches by one of DVI’s translation functions.

· Wrong codes (red) rows.

Display rows that contain mismatched embedded codes.

· Locked (yellow) rows.

Display rows that have been locked.

· Pending (cyan) rows.

Display rows that have been marked as pending.

· Autopropagated (light green) rows.

Display rows that have been automatically propagated.

You can use these options to assess how much work has been done or is left to do. This will allow you to produced detailed invoices, if you choose to charge different rates for sentences which were already in the memory database, etc.

3. If you change the type of rows displayed, click Calculate to update the count.

4. If you want to save the output of the word count to a text file, click on Save and select a file name.

Working with file formats XE "File formats" 
One of DVI’s distinctive advantages is that you have the possibility of working with a wide range of file formats. Whatever type of file you work with, DVI presents you with a uniform interface, displaying only translatable text, so you can work comfortably without having to worry about overwriting formatting and layout information.
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DV has built-in filters that allow you to work with:

· SGML XE "SGML files" 
· Microsoft Word XE "Word files" 
· RTF XE "RTF (Rich Text Format) files" 
· Microsoft PowerPoint XE "PowerPoint files" 
· Microsoft Excel XE "Excel files" 
· FrameMaker XE "FrameMaker files" 
· PageMaker XE "PageMaker files" 
· Interleaf XE "Interleaf files" 
· QuarkXPress XE "QuarkXPress .XTG files" 
· Help Contents XE "Help Contents files" 
·  XE "HTML Help files" 

 XE "ASP files" 

 XE "HTML files" HTML (including scripts and ASP), HTML Help

· Java Properties XE "Java Properties files" 
· RC XE "RC files" 
· C/C++/Java source files XE "C/C++/Java source files" 
· Trados Workbench XE "Trados Workbench:files" 
·  XE "IBM TM:files" IBM TM2 untranslated segments

Working with SGML files XE "SGML files" 
Unlike other file formats (HTML, FrameMaker, Word, etc.), SGML (Standardized General Markup Language) is not a real file format; it is a standard for tagging files, and for defining those tags. Since each customer may use a different set of tags, an SGML filter must be created with the SGML Filter Maintenance tool for each one.

SGML defines a standard for creating DTDs (Document Type Definition); for example, the W3C has DTDs for the various specifications of HTML; this means that HTML is a markup language defined according to SGML rules. You will probably be somewhat familiar with the structure and tags in HTML, so we will use it as an example in our explanations. In fact, Déjà Vu is supplied with an example SGML filter for HTML
.

Tags and keys

SGML files are text files that encode formatting, layout and image information using tags. Tags are in the format of:

<TAGNAME KEY1=“VALUE1” KEY2=“VALUE2” …>

A tag can contain keys, which specify values and attributes for the tag.

Since Déjà Vu does not need to interpret tags and keys, there are only two pieces of information that you must provide:

· Embeddable tags

If a tag is embeddable, this means that it can appear in the middle of a sentence, and that Déjà Vu should not split the sentence before or after this tag. For example, the <B> and <I> tags in HTML (which specify bold and italic attributes, respectively) are embeddable, while the <P> tag (which specifies a paragraph change) is not.

· Extractable keys

Certain tags may contain keys whose values are translatable, and must therefore be extracted. For example, the <IMG> tag in HTML (which inserts an image into the text) has the ALT=“[alternate text for the image]” key, which specifies the text to display if the browser cannot load the image. This text should be translated, so the key is extractable.

SGML DTDs do not clearly define this information, so you must mark tags and keys manually.

SGML also provides a way of defining encodings for special characters. For example, HTML encodes the ü character as &uuml;. Déjà Vu lets you specify such character encodings, so that when you import and export, these characters are properly interpreted.

To help you in the process of defining an SGML filter, the SGML Filter Maintenance tool can read the files you have to translate, and extract the set of tags and keys, as well as examples of their use.

· To create an SGML filter

1. Open SGML Filter Maintenance.

2. On the File menu, click on New Filter…
–Or–

Press Ctrl+N.

–Or–

Click on the [image: image186.bmp] button on the tool bar.

3. In the file selector that appears, enter the name and location of the filter you want to create. Déjà Vu will automatically add the .dvt extension.

4. You are asked whether you want to import data from another SGML filter. Click on No.

5. On the File menu, open the Import submenu and click on Read from SGML files.

6. Select the SGML files that you have to translate.

SGML Filter Maintenance will scan the files for all tags and keys and view them in the list.

7. On the Tags list, check all the tags that should be embedded (appear as an embedded code, rather than hidden) in a sentence.

8. For each tag, mark which of its keys should be extracted (visible for translation). If you are not sure, you can check the examples that Déjà Vu provides beside the list of keys. If there is text that appears to be translatable, you should mark the key as extractable.

9. Select the Characters tab. Here you must specify the tag and character delimiters. Unless the SGML files you are translating are non-standard, you should specify the following values:

· Open tag should be < and Close tag should be >.

· Open external character should be & and Close external character should be ;.

10. In the Characters list, fill in the following information:

· For each character, enter the actual character you want to display in DVI (for example, for &aacute; you should type á), and the ANSI/ASCII code for the character (for &aacute; the code is 225).

To define the encoding for special characters, it is useful to import them from the HTML filter file that is delivered with DejaVu.

· To import information from another SGML filter

1. On the File menu, open the Import submenu and click on Import from another file.

2. The Import what? window is displayed.

3. If you want to import tags and keys definitions, select Tags and keys.

4. If you want to import character definitions, select Characters.

5. Click on OK.

6. In the file selector that appears, select the filter from which you want to import information.

The supplied HTML filter (HTML.dvt), contains all the standard HTML/ SGML character definitions, so you may find it useful to import that information.

Note. When you import many SGML files to scan for tags and keys, the DVT filter file will become rather large, since it will also store all of the examples. After you have defined your filter file, you should click on Delete all examples on the Edit menu, in order to remove all the examples and reduce the size of the filter file.

· To use an SGML filter in DVI

1. When you create a project, specify SGML as the type of file you want to use.

2. In the Project configuration window, you will notice that there is an additional box where you can specify the SGML filter to use.

3. Click on Select.

4. In the file selector that appears, select the SGML filter you want to use.

5. Proceed as usual.

DVI will process the SGML files in the same way it processes other file formats—you should notice no difference.

Working with Microsoft Word files XE "Word files" 
DVI includes support for Microsoft Word documents (.DOC files). No special procedure is required to translate them; however, you must have Microsoft Word installed on your computer. DVI supports Word 6.0, 95 and 97, although it is recommended that you use Word 97, due to limitations in previous versions.

When configuring a Word DVI project you may control whether or not Déjà Vu will expose hidden text for translation. To do so, set or clear the Ignore hidden text option.

You can also tell Déjà Vu which footnotes not to expose. This is useful when translating help files.

Working with RTF (Rich Text Format) files XE "RTF (Rich Text Format) files" 
DVI adheres strictly to the Microsoft RTF standard, and will process any files that follow that standard. There are several non-Microsoft applications that export RTF files; in some situations, these applications may export RTF files that do not conform correctly to the standard. In such cases, it is possible that DVI may not be able to correctly import those RTF files. If you have any trouble, please contact Atril technical support.

When configuring an RTF DVI project you may control whether or not Déjà Vu will expose hidden text for translation. To do so, set or clear the Ignore hidden text option.

You can also tell Déjà Vu which footnotes not to expose. This is useful when translating help files.

Working with Microsoft PowerPoint files XE "PowerPoint files" 
As is the case with Word files, no special procedure is required to translate PowerPoint .PPT files. However, you must have Microsoft PowerPoint 97 (or later) installed on your computer.

Due to the way in which DVI works with PowerPoint files, once a translation is finished and ready to be exported, the original, unaltered .PPT file must be in the location from which it was imported. This is essential, since any slight modification to the file may prevent DVI from being able to export the final translation.

Working with Microsoft Excel files XE "Excel files" 
As is the case with Word files, no special procedure is required to translate Excel .XLS files. However, you must have Microsoft Excel 97 (or later) installed on your computer.

Due to the way in which DVI works with Excel files, once a translation is finished and ready to be exported, the original, unaltered .XLS file must be in the location from which it was imported. This is essential, since any slight modification to the file may prevent DVI from being able to export the final translation.

When configuring a DVI-Excel project you have the option to ‘Ignore red text’. This is normally used to translate bilingual or multilingual Excel files. All you have to do is to open the file in Excel and to paint red all columns but the one to be translated. After exporting, open the exported file and restore the original color.

Working with Adobe FrameMaker files XE "FrameMaker files" 
DVI includes support for Adobe FrameMaker 5 MIF files. Please note that DVI cannot import FrameMaker binary FM files; if you have an FM file that you want to translate in DVI, you must convert it to MIF format.

· To convert an FM file to MIF format

1. Open the file you want to convert in Adobe FrameMaker 5.

2. On the File menu, click on Save As…
3. In the file selector that appears, click on the Save as type dropdown list, and select FrameMaker Interchange Format (*.mif).

4. Specify a new name for the file.

5. Click on Save.

If you do not own a copy of FrameMaker, you should ask your client to send FrameMaker files in MIF format.

Working with Adobe PageMaker files XE "PageMaker files" 
DVI includes support for Adobe PageMaker 6.5 tagged text files.

To process Adobe PageMaker 6.5 documents, you must first save the text you want to translate as a “tagged text” file.

· To export a story

1. Open the file you want to process in PageMaker.

2. In Layout view, click anywhere on the story you want to export.

3. On the Edit menu, click on Edit Story.

4. On the File menu, open the Export… submenu and click on Text…
5. On the file selector that appears,

· Enter the name of the file you want to export the text to.

· Click on the Save as type dropdown list and select Tagged text.

· Make sure the Entire Story option is selected.

6. Click on Save.

Note. For each text chain (which constitutes a story) in the PageMaker document, you will have to repeat this procedure, since PageMaker does not provide an automated way of exporting all the stories together.

Once you have imported, translated and exported the tagged .TXT file in DVI, you have to replace the text into the PageMaker document.

· To re-import the story

1. Make a copy of the original file from which you exported the tagged text file.

2. Open the copy in PageMaker.

3. In Layout view, click anywhere on the original story you want to replace.

4. On the Edit menu, click on Edit Story.

5. On the File menu, click on Place…
6. On the file selector that appears, select the TXT file which DVI has exported (the one containing the final translation).

7. Make sure that the following options are selected:

· In the Place option group, Replacing entire story.

· In the Options option group, Retain format, Convert quotes, and Read tags.

8. Click on Open.

Working with QuarkXPress .XTG files XE "QuarkXPress .XTG files" 
To process QuarkXPress documents, you must first save the text you want to translate as an XPress Tag file.

· To export text as an XTG file

1. Open the file you want to process in QuarkXPress.

2. Click on the text box that contains the beginning of the text chain you want to export.

3. On the File menu, click on Save Text.

4. On the file selector that appears,

· Enter the name of the file you want to export the text to.

· Click on the Save as type dropdown list and select XPress Tags (*.xtg).

· Make sure the Entire Story option is selected.

5. Click on Save.

Note. For each text chain (which constitutes a story) in the XPress document, you will have to repeat this procedure, since QuarkXPress does not provide an automated way of exporting all the stories together. For jobs that contain a large number of stories, we recommend you obtain a copy of CopyFlow, a Quark​XPress XTension that allows you to export text from all the stories in the document to a single .XTG file. CopyFlow is developed and published by North Atlantic Publishing Systems Inc. (http://www.napsys.com/).

Once you have imported, translated and exported the .XTG file in DVI, you have to replace the text into the QuarkXPress document.

· To re-import the XTG file

1. Make a copy of the original file from which you exported the XTG file.

2. Open the copy in QuarkXPress.

3. Click on the text box containing the beginning of the story you exported.

4. On the Edit menu, click on Select All.

5. On the Edit menu, click on Delete.

6. On the File menu, click on Get Text.

7. On the file selector that appears, select the XTG file which DVI has exported (the one containing the final translation).

8. Make sure that the Include Style Sheets option is selected.

9. Click on Open.

Working with Interleaf ASCII files XE "Interleaf files" 
DVI can process Interleaf ASCII files exported with Interleaf 6 or later. Binary Interleaf files are not supported, so make sure that you save the Interleaf documents as ASCII, or ask your client to do so if you do not own a copy of Interleaf.

· To save an Interleaf document in ASCII format

1. Open the document in Interleaf

2. On the File menu, click on Save As.

3. On the file selector that appears,

· Enter the name of the file you want to save to.

· Click on the Save as type dropdown list and select Interleaf ASCII (*.doc).

4. Click on Save.

Working with IBM TM files XE "IBM TM:files" 
DVI can process IBM untranslated segments files

· To obtain the untranslated segments file for a particular file

1. Run IBM TM.

2. Locate your folder in TM's Folder List.

3. Double-click on it to open its list of files.

4. Right-click on the desired file. Select ‘Analyze’.

5. Check the "Create file containing untranslated segments" box.

6. Click on ‘Analyze’.

· Translation cycle for IBM TM files

1. Analyze the IBM TM documents to obtain the ‘untranslated segments’ files.

2. Import these ‘untranslated segments’ files into a DVI project.

3. Translate in DVI.

4. Export the finished translation from DVI.

5. Import the resulting files into the IBM TM memory database.

6. Re-analyze the IBM TM documents. This will yield a fully translated document.

7. Return the IBM TM folder to your client. The folder contains all translated documents and a memory database with all the material you have translated.

You can also export IBM TM’s memory databases to a file format that can be imported by DV’s Database Maintenance program

· To export a memory database from IBM TM

1. Display TM's Translation Memory List.

2. Right-click on the desired database. Select ‘Export’.

3. Select the ‘External’ format.

4. Specify the destination file.

5. Click on ‘Export’.

Working with Trados Workbench files XE "Trados Workbench:files" 
To process Trados Workbench files you need Microsoft Word 97 or later installed on your computer.

Due to the way in which DVI works with Trados Workbench files, once a translation is finished and ready to be exported, the original, unaltered file must be in the location from which it was imported. This is essential, since any slight modification to the file may prevent DVI from being able to export the final translation.

Database Maintenance XE "Database Maintenance" 
Database Maintenance is a workbench where you will find all the tools required for maintaining your memory databases: import/export, repairs, file alignment, manually adding or removing sentence pairs, etc.

Overview

When you open Database Maintenance, you are presented with the main window.
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Going from top to bottom, you will find:

· The menu bar.

· The tool bar.

· A row with four boxes: text locator, filter, client selector and subject selector.

· The scrolling table, with the list of sentences in the database.

· The complete source and target text for the row currently selected on the table.

· The status bar.

The behavior of the scrolling table and the source and target text boxes is the same as in DVI.

Managing memory databases

Opening a database XE "Memory databases:opening" 
Database Maintenance keeps a list of the last memory databases you have been using. If you want to open one of them, open the File menu, and click on the line with the name of the desired database:
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· To open a memory database

1. On the File menu, click on Open Database…
–Or–

Press Ctrl+O.

–Or–

Click on the [image: image189.bmp] button on the tool bar.

2. In the file selector window that appears, select the database you want to open and click on Open.

Creating a database XE "Memory databases:creating" 
· To create a memory database

1. On the File menu, click on New Database…
–Or–

Press Ctrl+N.

–Or–

Click on the [image: image190.bmp] button on the tool bar.

2. Database Maintenance opens a wizard to guide you through the process.
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3. Click on Next.
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4. Enter the name you want to give the new database. If necessary, use the Browse button to select or change the destination directory.

5. Click on Next.
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6. Select both the source and the target languages.

7. Click on Next
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8. Click on Finish to actually create the database.

Reversing a database XE "Memory databases:reversing" 
If you translate in both directions between two languages, you may find it useful to create a new database by reversing the language direction of another one. This allows you to build a memory database for, say, English-to-German if you have one for German-to-English.

· To reverse a memory database

1. On the Tools menu, click on Reverse database…
–Or–

Click on the [image: image195.bmp] button on the tool bar, and click on Reverse database…
2. On the first file selector that appears, select the memory database that you want to reverse.

3. On the second file selector, specify a name for the reversed database.

Importing external data XE "Memory databases:importing external data" 
Database Maintenance includes functions for importing external data into memory databases. This allows you, for example, to convert to Déjà Vu format data you have accumulated with other translation memory software, or even from data found on the Internet. 

· To import data

1. On the File menu, click on Import.

–Or–

Click on the [image: image196.bmp] button on the tool bar.

2. The Import database window appears.
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The formats supported are:

· Plain text

· Access XE "Access databases" 
· Excel XE "Excel files" 
· IBM TM database (exported as text).  XE "IBM TM:databases" 
· Trados WB database (exported as text) XE "Trados Workbench:databases" 
· TMX XE "TMX" 
·  XE "Catalyst files" Corel Catalyst

For text format you have the following options:

· Set or clear First row contains field names.

· Select the character set for the external file: OEM or ANSI. 

· Select the structure of the external file: 

· Tab delimited: text items in each row separated by the Tab character. 

· CSV: text items in each row surrounded by quotation marks and separated by commas. 

· Character delimited: text items in each row separated by an arbitrary character that you can specify. 

For Excel formats you have the following option: 

· Set or clear First row contains field names. 

3. Use the Select button to specify the external file. 

4. Press the Import button to open the external file: 
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5. Identify the source and target columns, and, if present, the client and subject columns. For each column use the field name selectors.
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6. Press the Go button to actually import the information into the current memory database. When the process is finished, you may wish to do some searching and replacing to clean up the imported data. 

Exporting a database XE "Memory databases:exporting" 
You can use this option to store a memory database in a compact format prior to deleting it from your hard disk.

This function is also convenient when you want to do extensive search/replace modifications to a memory database, which are probably easier to perform with a text editor. In this case you would first export the database to a bilingual file, edit this, delete the original database, and finally import the edited bilingual file into a new database.

· To export data

1. On the File menu, click on Export.

–Or–

Click on the [image: image200.bmp] button on the tool bar.

2. The Export database window appears.
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The formats supported are:

· Plain text

· Access XE "Access databases" 
· Excel XE "Excel files" 
· Trados XE "Trados Workbench:databases" 
· TMX XE "TMX" 
·  XE "Catalyst files" Corel Catalyst

For text format you have the following options:

· Set or clear Export field names as first row.

· Select the character set for the external file: OEM or ANSI.

· Select the structure of the external file:

· Tab delimited: text items in each row separated by the Tab character.

· CSV: text items in each row surrounded by quotation marks and separated by commas.

· Character delimited: text items in each row separated by an arbitrary character that you can specify.

For Excel formats you have the following option:

· Set or clear Export field names as first row.

3. Use the Select button to specify the external file.

4. If you want to filter the database, press the Build expression button.
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Use the various dropdown lists and text boxes to build the filter expression.

The expression in this example selects all rows that belong to client 1 and whose subjects are in group 004 (Data Processing). You can press the See expression button to display the logical expression that will be used by Database Maintenance. Press the OK button when you have built the expression according to your needs.

Instead of using the Build expression window, you can enter the expression directly into the text box.

5. In the Export as area, mark the fields you want to export. Unless you have selected the Text format and unchecked the Export field names as first option, you can change the names that will be given to fields in the exported file.

6. Press the Export button to begin exporting to the external file.

If the format selected is Access or Excel, you will be asked to confirm or change the table name that will be created in the external file:
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7. Database Maintenance will export the database in the background. You may press the Exit button and continue working on something else if you wish.

8. When the operation is finished, Database Maintenance will display a confirmation message.
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Compacting a database XE "Memory databases:compacting" 
Compacting a database will free disk space by rewriting the data to a new, temporary file, thus removing data fragmentation. The temporary file is then copied back to the original file. Compacting requires that disk space be available for the temporary file, either on the hard disk where the original database resides, or on any other hard disk in the system.

· To compact a memory database

· On the Tools menu, click on Compact database.

–Or–

Click on the [image: image205.bmp] button on the tool bar, and select Compact database.

Notice that you can’t compact the currently open database; if you want to compact it, you must first open a different one.

Repairing a database XE "Memory databases:repairing" 
Repairing is necessary when a database has become corrupted, probably because of an abnormal program ending caused by a power outage or by hardware problems.

· To repair (and compact) a memory database

· On the Tools menu, click on Repair database.

–Or–

Click on the [image: image206.bmp] button on the tool bar, and select Repair database.

Notice that you can’t repair the database currently open; if you want to repair it, you must first open a different one. (At any rate, you probably will not be able to open a corrupted database.)

Maintenance with SQL commands XE "Memory databases:maintenance with SQL commands" 

 XE "SQL" 
You can execute SQL commands to perform maintenance operations on your memory database. If is possible to run any SQL commands, even those that can destroy your database. You must, therefore, be very careful when using this resource. If in doubt, please write to support@atril.com and describe what you need to achieve.

· To run an SQL command

1. On the Tools menu, open the SQL submenu and click on Execute.

2. Enter the text of the command.

Use the ‘Available fields’ list to see which fields you can mention in your command and to minimize the risk of spelling errors.

Reusing previous material — Aligning texts XE "Aligning texts" 

 XE "Memory databases:aligning texts" 
The Align function aligns or synchronizes a source language file with a target language file, and adds the resulting pairs of sentences to a memory database. This is the function you should use for building memory databases from old translations.

· To align a pair of files

1. On the File menu, click on Align.

–Or–

Click on the [image: image207.bmp] button on the tool bar.

2. Database Maintenance opens a wizard that will guide you through the process:
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3. Click on Next.
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4. If you are creating a new alignment work file, click on Next.
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5. Press the Create button to specify the path and name for the alignment work file. Click on Next.
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6. Select the format for the two files (source language and target language) you want to align. Use the two Select buttons to specify the two files. Click on Next.

[image: image212.png]Flease select the appropiite languags for each e

Target language

Sparish

Souse ngusge
[Engien

Sundanese
Swahil

Swedsh

Tagalog

Taik =
Tami

Tatar -

<Back Next> Cancel





7. Select source and target languages using the two dropdown lists. Click on Next.
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8. Click on Finish.

At this point, Database Maintenance reads the source and target files to break paragraphs into sentences. In this process Déjà Vu uses two different sets of splitting rules and exceptions, one for the source language and another for the target language. (You can specify both sets in the DejaVu settings window.)

When Database Maintenance has finished reading the files, it displays the File alignment window:
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This is where you correct any misalignments between the lists of sentences extracted from the two files.

There is a misalignment in this example caused by the fact that Déjà Vu has used a default rule (“.^w”, full stop followed by white space) to break the paragraph after “Fig.”. You might define an exception to this rule: “don’t break after ‘full stop followed by white space’ if this is followed by a digit”.
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With this exception in effect, the two sentences would have been aligned correctly.

Experience will tell you how you should modify the sets of rules and exceptions for the languages with which you work usually.

The resources you have for correcting misalignments are:

· [image: image216.png]


 realigns the files by joining the current source sentence with the next one, while leaving target sentences as they are.

· [image: image217.png]Spit source



 splits the current source sentence at the position marked by the cursor in the current source sentence box.

· [image: image218.png]


 erases the current source.

The three right-hand side buttons work likewise, but affect target sentences.

You may find it easier to use the keyboard than the buttons. These are the equivalent keystrokes:

	Button
	Key
	Button
	Key

	JoinS
	F3
	JoinT
	F6

	SplitS
	F4
	SplitT
	F7

	EraseS
	F5
	EraseT
	F8


It should be noted that all alignment operations are performed on the work file; your source and target disk files will not be affected in any way.

· To spell check the aligned text

· On the Tools menu, click on Check spelling.

–Or–

Press F7.

· To set a client and a subject

· On the File menu, click on Set Client and Subject.
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· To send the aligned text to a database

1. On the File menu, click on Feed.

2. Database Maintenance will display a file selector with which you must choose the destination memory database.

Editing the database

Filtering the database – the easy way XE "Memory databases:filtering:the easy way" 
You can ask Database Maintenance to filter the database, i.e., to display only those rows that contain certain words in the source field.

· To filter the display

1. Enter the desired words in the filter box.

2. Click on the [image: image220.bmp] button on the toolbar.

You can enter as many words as you wish, but only the first three will be considered for the filter. Notice also that words with fewer characters than the Minimum number of characters in a word XE "Minimum number of characters in a word"  specified for the source language will not be considered.

Filtering the database with SQL queries XE "Memory databases:filtering:with SQL queries" 

 XE "SQL" 
For more complex filtering you can use SQL queries. Déjà Vu will display only those records that meet the criteria you specify, and the criteria can be as elaborate as necessary.

· To run an SQL query

1. On the Tools menu, open the SQL submenu and click on Select.

2. Enter the text of the query.

For those familiar with SQL, the text to enter here is the part that comes after the WHERE clause in SELECT queries. Use the ‘Available fields’ list to see which fields you can mention in your query and to minimize the risk of spelling errors.

Sorting the database XE "Memory databases:sorting" 
By default, sentences are shown in the order in which they were added to the database.

· To switch the display sorting

· To switch to alphabetical ordering, click on the [image: image221.bmp] button on the toolbar.

· To switch back to the original ordering, click on the same button (whose image will have changed to [image: image222.bmp]).

When you switch from one mode to the other, Database Maintenance will keep the same current record.

While in alphabetical order you can use the text locator to quickly jump to a different place. As you type into the text locator, Database Maintenance will reposition to the first record that begins with the letters you have written so far. This action is artificially delayed so that you will have time to type in a few letters before the repositioning occurs.
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Adding rows

· To manually add a sentence pair

· On the Edit menu, click on Add.

–Or–

Click on the [image: image224.bmp] button on the tool bar.

This creates a new blank row. You can then enter your text in the source and target boxes, and select client and subject using the corresponding selectors. The database will be updated when you move to a different row.

Deleting rows

· To permanently remove the current sentence pair

· On the Edit menu, click on Delete.

–Or–

Click on the [image: image225.bmp] button on the tool bar.

Changing the client and subject information XE "Memory databases:client/subject information" 
For rows added by DVI, client and subject will be those specified for the DVI project. For rows added manually with Database Maintenance, client and subject will be blank.

You change this information by selecting a client or subject from the corresponding dropdown list.

Spell checking XE "Memory databases:spell checking" 
· To activate spell checking

1. On the Tools menu, click on Check spelling.

–Or–

Press F7.

–Or–

Click on the [image: image226.bmp] button on the tool bar.

2. You will be offered the following options:

· Check source or target text.

· Check all rows, from the current one onwards, or only those that haven’t been checked before.

Spell checking in the Database Maintenance module works in the same way as in DVI. Please refer to Spell checking on page 115.

Controlling rows with duplicate source XE "Duplicate source, rows with" 
You can use the right-most button on the toolbar to find and display sets of rows with the same source text.

· To find rows with duplicate source

1. Click the arrow on the right-most button on the toolbar and select the first option.
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Select the desired options on the ‘Find duplicates’ window.
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DV will highlight rows with duplicate source by painting magenta the corresponding source cells on the table.

Using the same button and menu you can revert to displaying all rows. You can also ask DV to forget about duplicates rows.

Terminology Maintenance XE "Terminology databases" 
Terminology Maintenance is a workbench where you will find all the tools required for maintaining your terminology databases: import/export, repairs, manually adding or removing term pairs, etc.

Overview

When you open Terminology Maintenance, you are presented with the main window.
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Going from top to bottom, you will find:

· The menu bar.

· The tool bar.

· A row with six boxes: gender, number and part of speech selectors for source and target terms.

· A row with three boxes: text locator, client selector and subject selector.

· The scrolling table, with the list of term pairs in the database.

· The complete source and target text for the row currently selected on the table.

· The source and target definitions for the row currently selected on the table.

· The status bar.

The behavior of the scrolling table and the source and target text boxes is the same as in DVI.

Managing terminology databases

Opening a database XE "Terminology databases:opening" 
Terminology Maintenance keeps a list of the last terminology databases you have been using. If you want to open one of them, open the File menu, and click on the line with the name of the desired database:
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· To open a terminology database

1. On the File menu, click on Open Database…
–Or–

Press Ctrl+O.

–Or–

Click on the [image: image231.bmp] button on the tool bar.

2. In the file selector window that appears, select the database you want to open and click on Open.

Creating a database XE "Terminology databases:creating" 
· To create a terminology database

1. On the File menu, click on New Database…
–Or–

Press Ctrl+N.

–Or–

Click on the [image: image232.bmp] button on the tool bar.

2. Terminology Maintenance opens a wizard to guide you through the process.
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3. Click on Next.

[image: image234.png]Choose database name and directory

Type the name you wauld ke your database to have:

[ErEsComp

Defau il create the detabase inthe fllowing diector.
T create the database in this diectory, cick Nest.

T create the database in another diectary, clck Browse
and select another diector.

Destinaton Ditectory

DADVdatabases

<Back Next> Cancel





4. Enter the name you want to give the new database. If necessary, use the Browse button to select or change the destination directory.

5. Click on Next.
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6. Select both the source and the target languages.

7. Click on Next
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8. Click on Finish to actually create the database.

Reversing a database XE "Terminology databases:reversing" 
If you translate in both directions between two languages, you may find it useful to create a new database by reversing the language direction of another one. This allows you to build a terminology database for, say, English-to-German if you have one for German-to-English.

· To reverse a terminology database

1. On the Tools menu, click on Reverse database…
–Or–

Click on the [image: image237.bmp] button on the tool bar, and click on Reverse database…
2. On the first file selector that appears, select the terminology database that you want to reverse.

3. On the second file selector, specify a name for the reversed database.

Importing external data XE "Terminology databases:importing external data" 
Terminology Maintenance includes functions for importing external data into terminology databases. This allows you, for example, to convert to Déjà Vu format data you have accumulated with other translation memory software, or even from data found on the Internet. 

· To import data

1. On the File menu, click on Import.

–Or–

Click on the [image: image238.bmp] button on the tool bar.

2. The Import database window appears.
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The formats supported are:

· Plain text

· Access XE "Access databases" 
· Excel XE "Excel files" 
· IBM TM dictionary XE "IBM TM:dictionaries" 
· Corel Catalyst XE "Catalyst files" 
For text format you have the following options:

· Set or clear First row contains field names.

· Select the character set for the external file: OEM or ANSI. 

· Select the structure of the external file: 

· Tab delimited: text items in each row separated by the Tab character. 

· CSV: text items in each row surrounded by quotation marks and separated by commas. 

· Character delimited: text items in each row separated by an arbitrary character that you can specify. 

For Excel formats you have the following option: 

· Set or clear First row contains field names. 

3. Use the Select button to specify the external file. 

4. Press the Import button to open the external file: 
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5. Identify the source term and target term columns, and, if present, columns for client, subject and grammatical information. (Use the horizontal scroll bar to display columns not initially visible.) For each column use the field name selectors:
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6. By default, the following values are converted to the Déjà Vu grammatical attributes:

	External value
	Déjà Vu attribute

	M
	Masculine

	F
	Feminine

	N
	Neutral

	S
	Singular

	P
	Plural

	N
	Noun

	A
	Adjective

	T
	Article

	V
	Verb

	R
	Adverb

	P
	Preposition

	O
	Pronoun

	C
	Conjunction

	I
	Interjection

	E
	Proper noun


7. If the grammatical attributes are represented in the external file by values different from those listed above, check the Map values option and click on the Define button:
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8. Modify entries on the second column of each table to reflect the actual values to be found in the external file. Press the OK button when you are finished.

9. Press the Go button to actually import the information into the current terminology database. When the process is finished, you may wish to do some searching and replacing to clean up the imported data.
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Exporting a database XE "Terminology databases:exporting" 
You can use this option to store a terminology database in a compact format prior to deleting it from your hard disk.

This function is also convenient when you want to do extensive search/replace modifications to a terminology database, which are probably easier to perform with a text editor. In this case you would first export the database to a bilingual file, edit this, delete the original database, and finally import the edited bilingual file into a new database.

· To export data

1. On the File menu, click on Export.

–Or–

Click on the [image: image244.bmp] button on the tool bar.

2. The Export database window appears.
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The formats supported are:

· Plain text

· Access XE "Access databases" 
· Excel XE "Excel files" 
· Corel Catalyst XE "Catalyst files" 
For text format you have the following options:

· Set or clear Export field names as first row.

· Select the character set for the external file: OEM or ANSI.

· Select the structure of the external file:

· Tab delimited: text items in each row separated by the Tab character.

· CSV: text items in each row surrounded by quotation marks and separated by commas.

· Character delimited: text items in each row separated by an arbitrary character that you can specify.

For Excel formats you have the following option:

· Set or clear Export field names as first row.

3. Use the Select button to specify the external file.

4. If you want to filter the database, press the Build expression button.
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Use the various dropdown lists and text boxes to build the filter expression.

The expression in this example selects all rows that belong to client 1 and whose subjects are in group 004 (Data Processing). You can press the See expression button to display the logical expression that will be used by Database Maintenance. Press the OK button when you have built the expression according to your needs.

Instead of using the Build expression window, you can enter the expression directly into the text box.

The field names you can use in the filter expression are:

	SourceTerm
	TargetTerm

	SourceGender
	TargetGender

	SourceNumber
	TargetNumber

	SourcePartOfSpeech
	TargetPartOfSpeech

	Client
	

	Subject
	


5. To see on the table the filtered database, press the Apply button.

In the Export as area, mark the fields you want to export. Unless you have selected the Text format and unchecked the Export field names as first option, you can change the names that will be given to fields in the exported file. (Use the horizontal scroll bar to display columns not initially visible.)

6. By default, the following values are converted to the Déjà Vu grammatical attributes:

	External value
	Déjà Vu attribute

	M
	Masculine

	F
	Feminine

	N
	Neutral

	S
	Singular

	P
	Plural

	N
	Noun

	A
	Adjective

	T
	Article

	V
	Verb

	R
	Adverb

	P
	Preposition

	O
	Pronoun

	C
	Conjunction

	I
	Interjection

	E
	Proper noun


7. If the grammatical attributes are represented in the external file by values different from those listed above, check the Map values option and click on the Define button:
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8. Press the Export button to begin exporting to the external file.

If the format selected is Access or Excel, you will be asked to confirm or change the table name that will be created in the external file:
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9. Terminology Maintenance will export the database in the background. You may press the Exit button and continue working on something else if you wish.

10. When the operation is finished, Terminology Maintenance will display a confirmation message.
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Compacting a database XE "Terminology databases:compacting" 
Compacting a database will free disk space by rewriting the data to a new, temporary file, thus removing data fragmentation. The temporary file is then copied back to the original file. Compacting requires that disk space be available for the temporary file, either on the hard disk where the original database resides, or on any other hard disk in the system.

· To compact a terminology database

· On the Tools menu, click on Compact database.

–Or–

Click on the [image: image250.bmp] button on the tool bar, and select Compact database.

Notice that you can’t compact the currently open database; if you want to compact it, you must first open a different one.

Repairing a database XE "Terminology databases:repairing" 
Repairing is necessary when a database has become corrupted, probably because of an abnormal program ending caused by a power outage or by hardware problems.

· To repair (and compact) a terminology database

· On the Tools menu, click on Repair database.

–Or–

Click on the [image: image251.bmp] button on the tool bar, and select Repair database.

Notice that you can’t repair the database currently open; if you want to repair it, you must first open a different one. (At any rate, you probably will not be able to open a corrupted database.)

Maintenance with SQL commands XE "Terminology databases:maintenance with SQL commands" 

 XE "SQL" 
You can execute SQL commands to perform maintenance operations on your terminology database. If is possible to run any SQL commands, even those that can destroy your database. You must, therefore, be very careful when using this resource. If in doubt, please write to support@atril.com and describe what you need to achieve.

· To run an SQL command

1. On the Tools menu, open the SQL submenu and click on Execute.

2. Enter the text of the command.

Use the ‘Available fields’ list to see which fields you can mention in your command and to minimize the risk of spelling errors.

Editing the database XE "Terminology databases:editing" 
Locating a particular term

Terms are always shown in alphabetical order.

You can use the text locator to quickly jump to any place in the database. As you type into the text locator, Terminology Maintenance will reposition to the first record that begins with the letters you have written so far. This action is artificially delayed so that you will have time to type in a few letters before the repositioning occurs.

Filtering the database with SQL queries XE "Terminology databases:filtering with SQL queries" 

 XE "SQL" 
For more complex filtering you can use SQL queries. Déjà Vu will display only those records that meet the criteria you specify, and the criteria can be as elaborate as necessary.

· To run an SQL query

1. On the Tools menu, open the SQL submenu and click on Select.

2. Enter the text of the query.

For those familiar with SQL, the text to enter here is the part that comes after the WHERE clause in SELECT queries. Use the ‘Available fields’ list to see which fields you can mention in your query and to minimize the risk of spelling errors.

Adding rows

· To manually add a sentence pair

· On the Edit menu, click on Add.

–Or–

Click on the [image: image252.bmp] button on the tool bar.

This creates a new blank row. You can then enter your terms in the source and target text boxes, and your definitions in the two lower boxes. You can also set values for source and target gender, number and part of speech, and select client and subject using the corresponding selectors. The database will be updated when you move to a different row.

Deleting rows

· To permanently remove the current sentence pair

· On the Edit menu, click on Delete.

–Or–

Click on the [image: image253.bmp] button on the tool bar.

Changing the client and subject information XE "Terminology databases:client/subject information" 
For rows added by DVI, client, subject and grammatical information will be those you specified on DVI’s terminology window. For rows added manually with Terminology Maintenance, all this information will be blank.

Select client, subject, genders, numbers and parts of speech from the corresponding dropdown lists. There are techniques for quickly locating clients and subjects.

Spell checking XE "Terminology databases:spell checking" 
· To activate spell checking

1. On the Tools menu, click on Check spelling.

–Or–

Press F7.

–Or–

Click on the [image: image254.bmp] button on the tool bar.

2. You will be offered the following options:

· Check source or target text.

· Check all rows, from the current one onwards, or only those that haven’t been checked before.

Spell checking in the Terminology Maintenance module works in the same way as in DVI. Please refer to Spell checking on page 115.

Controlling rows with duplicate source XE "Duplicate source, rows with" 
You can use the right-most button on the toolbar to find and display sets of rows with the same source text.

· To find rows with duplicate source

1. Click the arrow on the right-most button on the toolbar and select the first option.
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Select the desired options on the ‘Find duplicates’ window.
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DV will highlight rows with duplicate source by painting magenta the corresponding source cells on the table.

Using the same button and menu you can revert to displaying all rows. You can also ask DV to forget about duplicates rows.

Database Conversion Wizard XE "Database Conversion Wizard" 
Overview

This program helps you in converting memory databases from Déjà Vu 1.x format to the current format.

Using the wizard

· To convert a DV 1.x database

1. Start the Database Conversion Wizard.
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2. Click on Next.
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3. Use the Select button to choose the original Déjà Vu 1.x database. Click on Next.
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4. Use the Select button to specify the destination database, or the Create button if you wish to create a new database at this time. Click on Next.
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5. The Conversion Wizard opens the original database and displays the first few rows. Check that the original database contains text in the languages of the destination database. (If you have just created a destination database, you must specify the two languages now.) Click on Next.
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6. Click on Next to confirm that you want to start the conversion.
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7. Click on Next when the progress indicator reaches 100%.
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8. Click on Finish to exit the program.

TermWatch XE "TermWatch" 
Overview

TermWatch is a program that lets you access terminology databases from any (or almost any) Windows application. You can define key combinations that, when pressed, will look up the selected word in the terminology database and

· insert the target term into the calling application, replacing the selected text, or

· copy the target term to the clipboard, or

· present all matches on a table (as for lookups started from DVI)

All the terminology maintenance functions are accessible through TermWatch, including import/export facilities.

Before TermWatch can work, you must create and select a terminology database.

Using TermWatch

When you run TermWatch, its icon is displayed on the Windows Taskbar tray:
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To use TermWatch from a Windows application (for example, Word), select the word(s) you want to look up and press one of the following:

· Ctrl+7 to look up the word(s) in the current terminology database and insert the found target term (if any) into the calling application, replacing the selected text.

· Ctrl+8 to look up the word(s) in the current terminology database and copy the found target term (if any) to the clipboard.

· Ctrl+9 to look up the word in the current terminology database and present all matches in a table (as for lookups started from DVI).

In the latter case, you can navigate through the list of matches by using the table’s scrollbar or the following keystrokes:

· Ctrl+PgDn to go to the end of the list.

· Ctrl+PgUp to go to the beginning of the list.

· Ctrl+DownArrow to go to the next match.

· Ctrl+UpArrow to go to the previous match.

You can press:

· [image: image265.bmp] or Ctrl+L to retrieve the target term and insert it to the left of the selected text

· [image: image266.bmp] or Ctrl+U to retrieve the target term and insert it in place of the selected text

· [image: image267.bmp] or Ctrl+R to insert the retrieved term and insert it to the right of the selected text

· [image: image268.bmp] or Ctrl+B to just copy the retrieved term to the Windows clipboard

· [image: image269.bmp] or Esc to exit the window without retrieving anything

Notice that some applications do not respond properly (or at all) to the standard Windows commands used by TermWatch. For example, in FrameMaker 5 it is necessary to press Ctrl+C before using any of the above keystrokes.

TermWatch Settings

· To open the TermWatch settings window

· Locate the TermWatch on the Windows Taskbar tray and click on it.

The following menu will be displayed:
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Click on the menu’s first option.
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If you have already created a terminology database, you can click on the Select button to open it. (If not, open the Tools menu and click on Terminology database maintenance to launch that program.)

The Source language and Target language boxes are filled automatically with information read from the terminology database.

If you wish, you can use the corresponding dropdown lists to select a client and a subject. These values will be used when scanning the database. (All other conditions being the same, a match is considered better than another if its subject and/or client information is the same as that specified here.)

By default, the three keystrokes used for making TermWatch consult the database are Ctrl+7, Ctrl+8 and Ctrl+9. If you wish to change any of these, click on the corresponding Select button and press the desired key combination. Press the OK button when finished.
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Activate the Terse display of matches option if you want to display matches without grammatical, subject and client information.

You can activate Auto-load TermWatch if you want TermWatch to load automatically whenever Windows is started.

The Terminology database maintenance option on the Tools menu launches Terminology Maintenance, the program that you must use to create terminology databases, to manually add terms to them, to import glossaries from external files, etc.

The DejaVu settings option on the Tools menu opens the DejaVu settings window. You need to access this window for creating or modifying client and subject information, and for setting font attributes for each language. The remaining settings are not used by TermWatch.

Suspending/resuming TermWatch

· To suspend or resume TermWatch

1. Locate the TermWatch on the Windows Taskbar tray and click on it. The following menu will be displayed:
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2. Click on the menu’s second option.

When suspended, TermWatch ignores keystrokes addressed to it. You can suspend TermWatch temporarily if you are going to use a program that expects the same keystrokes.

Appendix
Keyboard shortcuts for Déjà Vu Interactive XE "Keyboard shortcuts" 
	Ctrl+O
	Open project

	Ctrl+Q
	Exit DVI

	Ctrl+PgUp
	Go to beginning of table

	Ctrl+PgDn
	Go to end of table

	Ctrl+UpArrow
	Go to previous row

	Alt+UpArrow
	Go to previous untranslated row

	Alt+LeftArrow
	Go to the previous sentence without triggering any Auto… effects and without changing row status

	Ctrl+DownArrow
	Go to next row and launch AutoSend, AutoPropagate and AutoAssemble (if enabled)

	Alt+DownArrow
	Go to next untranslated row and launch AutoSend, AutoPropagate and AutoAssemble (if enabled)

	Alt+RightArrow
	Go to the next sentence without triggering any Auto… effects and without changing row status

	Ctrl+A
	Assemble translation for current source sentence

	F3
	Join current sentence with next

	F4
	Split source sentence

	F5
	Insert source text at the beginning of target text

Combined with Ctrl: replace rather than insert

Combined with Alt: transfer only embedded codes

Combined with Shift: affect all visible rows

	F6
	See current source in context

	F7
	Check spelling

	Shift+F7
	Check terminology (single row)

	Ctrl+Shift+F7
	Check terminology

	F8
	Insert AutoText

	F9
	Toggle codes visible

	Shift+F3
	Toggle case

	Ctrl+Shift+L
	Toggle row locking

	Ctrl+D
	Copy next code from source to target inserting at the cursor position

	Ctrl+Shift+C
	Jump to the next row with wrong embedded codes

	Ctrl+Shift+F3
	Quickly fix embedded codes for current row

	Ctrl+B
	Set bookmark

	Ctrl+G
	Go to bookmark

	Ctrl+H
	Search/Replace

	Ctrl+M
	Mark row (or selected rows) as pending

	Ctrl+U
	Unpaint row (or selected rows)

	Ctrl+Y
	Toggle ‘Prevent row from being sent to the MDB/Allow row to be sent to the MDB’

	Ctrl+R
	Pretranslate

	Ctrl+S
	Scan for current source or selection

	Ctrl+F9
	Add pair or selections to lexicon

	Ctrl+F11
	Send pair or selections to terminology database

	Ctrl+F12
	Send pair or selections to memory database

	Shift+F12
	Send project to memory database

	Ctrl+F
	Export two columns to text file

	Ctrl+K
	Display character map

	F11
	Propagate current translation in current file

	F12
	Propagate current translation to all files

	Ctrl+Z
	Undo last edit

	Shift+Ctrl+F8
	Check ‘ Multiple exact match (dark green)’ rows.

	Ctrl+N
	Go to next row in Portions found window

	Ctrl+P
	Go to previous row in Portions found window

	Ctrl+L
	Go to next row in Sentences found window

	Ctrl+O
	Go to previous row in Sentences found window

	Alt+xx
	Copy from Portions found to target box in DVI

	Ctrl+T 
	Insert target from Portions found window DVI target text box at cursor position

	Shift+Ctrl+T
	Replace target text in DVI with target copied from Portions found window

	Ctrl+E
	Insert target from Sentences found window DVI target text box at cursor position

	Shift+Ctrl+E
	Replace target text in DVI with target copied from Sentences found window

	Ctrl+Shift+N
	Moves the current word or selection to after the next word

	Ctrl+Shift+P
	Moves the current word or selection to before the previous word
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AutoText, 56
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clients, 67

database, 58

fonts, 63

general, 54

sentence delimiters, 59

subjects, 65

Options window, 18

Organizing your files, 17

Output directory, 70

PageMaker files, 141, 147

Populating, 126

Portions found window, 96

PowerPoint files, 141, 146

PowerScan, 90

Pretranslating, 34, 85

Project window, 40

Projects, 12

compacting, 78

configuration, 22. See
creating, 20

exporting translations, 75

importing files, 73

maintenance with SQL commands, 78

management, 131

pretranslating, 85

removing files, 74

repairing, 78

satellites, 131, 132

security, 133

working with, 67

Propagating, 127

QuarkXPress .XTG files, 141, 148

RC files, 141

Row locking, 137

Rows selector, 43, 52

RTF (Rich Text Format) files, 141, 145

Satellite projects, 131, 132

Scanning for a sentence, 87

PowerScan, 90

with word stems, 90

Scrolling table, 43

Search and replace, 124

Selecting rows, 49

Send to memory database

pairs, 111

selections, 111

whole project, 111

Send to terminology database

pairs, 113

selections, 113

Sentence delimiters, 59, 61

Sentences found window, 99

SGML files, 141, 142

SGML Filter Maintenance, 15

Sorting, 47

Source common directory, 70

Spell checking, 115

Split text area horizontally, 44, 55

Splitter bar, 44

Splitting sentences, 77

SQL, 49, 78, 162, 169, 186, 187

Status bar, 43

Subjects, 65

Symbols, 62

Target language selector, 42, 47

Target languages, 71

Terminology checks, 56, 100

Terminology databases, 14, 91, 173

client/subject information, 188

compacting, 185

creating, 175

editing, 187

exporting, 181

filtering with SQL queries, 187

importing external data, 177

maintenance with SQL commands, 186

opening, 174

repairing, 186

reversing, 177

spell checking, 188

Terminology Maintenance, 15

TermWatch, 15, 194

Text locator, 41, 47

TMX, 157, 160

Tool bar, 41

Trados Workbench

databases, 157, 160

files, 142, 151

Tutorial, 17

Unpaint, 52

Upercase, 62

What is Déjà Vu?, 1

Word count, 38, 138

Word files, 141, 145

Workflow, 15
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� If you created a directory structure different from the one we have recommended, place the files in the appropriate directories.


� In most cases, the default sentence splitting rules should be valid. For more information on sentence splitting rules, see � REF _Ref480186009 \h � \* MERGEFORMAT �Sentence delimiters� on page � PAGEREF _Ref480185984 \h ��59�.


� You will find that most of the common actions associated with an object will appear in a popup context menu when you right click on it.


� You can also select the next sentence on the table. However, pressing Ctrl+( keeps the target text box active, making it easier and quicker to move to the next sentence; it also validates the embedded codes in the target sentence.


� A light gray background on a table cell, in general, indicates that you have edited that translation.


� By default, Déjà Vu will split after a colon followed by a space, but not after a colon followed by a tab. You can, of course, change these rules in the options window. For more information, see � REF _Ref480186009 \h � \* MERGEFORMAT �Sentence delimiters� on page � PAGEREF _Ref480185984 \h ��59�.


� In this manual, we will always refer to a pair of source and target (translated) sentences as a sentence pair.


� An exact match is one in which the source sentence found is identical to the sentence we were searching for. A fuzzy match is a sentence which is similar, but not identical, to the one we were looking for.


� You will find splitter bars in almost every DVI window that contains a scrolling table and several text boxes.


� Locking a row prevents it from being edited. See � REF _Ref480140696 \h � \* MERGEFORMAT �Row locking� on page � PAGEREF _Ref480140717 \h ��137�.


� See � REF _Ref440652103 \h � \* MERGEFORMAT �Propagating a translation� on page � PAGEREF _Ref440652112 \h ��127�.


� Please note that, while you can change the values for ‘Minimum number…’ at any time, they will only affect those sentences you add to the memory database after you change the value. To effect the change on the whole memory database, you should use the Repair function in the Database Maintenance module.


� Please note that, if you redefine characters, you should also use the Repair function in the Database Maintenance module.


� In order to select a client for the project, you must use the Tools/Options window to create it. See � REF _Ref480192418 \h � \* MERGEFORMAT �Configuring Déjà Vu� (� REF _Ref480192384 \h � \* MERGEFORMAT �Clients�) on page � PAGEREF _Ref480192450 \h ��67�.


� Déjà Vu will present you with the default extension for the file format you selected when you created the project. However, you may want to add other extensions.


� To drag a language, place the mouse pointer over it, press the left mouse button and, while keeping it pressed, move the mouse pointer to the Target languages list.


� Incorrect splitting may also occur as a result of incorrect labeling of SGML tags as embeddable or non-embeddable. See � REF _Ref440652209 \h � \* MERGEFORMAT �Working with SGML files� on page � PAGEREF _Ref440652213 \h ��142�.


� During compacting, DVI will automatically create its temporary files in the first hard drive it finds which has enough free space.


� You can only modify an embedded code inside a target sentence.


� An exact match is one in which the source sentence found is identical to the sentence you were searching for. A fuzzy match is a sentence similar, but not identical, to the one you were looking for.


� This is useful if you have previously pretranslated this file.


� All other conditions being the same, a match is considered better than another if its subject and/or client information is the same as that specified for the project.


� See The project lexicon on page � PAGEREF _Ref441852154 \h ��101�.


� If you delete a large number of entries from the lexicon in order to free some disk space, you may want to compact the project by opening the Tools menu, opening the File utilities submenu and clicking on Compact project.


� See � REF _Ref440652351 \h � \* MERGEFORMAT �The Learn function� on page � PAGEREF _Ref440652355 \h ��93�.


� If the lexicon consists mainly of single terms rather than expressions or phrases, you should send it to the terminology database; otherwise, it is best to send it to the memory database.


� Déjà Vu also includes a specific filter for HTML; we recommend you use this filter rather than the example SGML one.





